Download Manager closes on Firefox exit

RESOLVED INVALID

Status

()

Firefox
General
RESOLVED INVALID
8 years ago
7 years ago

People

(Reporter: makitk, Unassigned)

Tracking

3.6 Branch
All
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.2.8) Gecko/20100803 Gentoo Firefox/3.6.8
Build Identifier: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.2.8) Gecko/20100803 Gentoo Firefox/3.6.8

The old behavior was that Firefox would leave the Download Manager be, leaving a user with the option of either opening the files they downloaded from the Download Manager or leaving some background downloads running without the need for the complete Firefox instance to be loaded as well. This behavior was preferable to me personally.

The new situation is that, regardless of whether downloads are running, the Download Manager is closed upon Firefox exit. This may cause half-downloaded files, or a loss of the download history.

Reproducible: Always

Steps to Reproduce:
1. Start Firefox and ensure the "Show the Downloads window when downloading a file" is checked in Preferences -> General.
2. Download a (large) file and the Downloads window should pop up.
3. Before the download is complete, exit the Firefox window. The download window will quit without the user being prompted whether or not they wish to continue the download that's underway.
Actual Results:  
The download manager exited upon firefox exit, breaking off downloads in progress without the user being prompted.

Expected Results:  
The download manager should have remained open so that the download could properly finish. Alternatively, Firefox should have prompted the user with a dialog along these lines:
"You're still downloading a file! Exiting firefox will cancel the download. Really quit? Y/N"
(Reporter)

Updated

8 years ago
Version: unspecified → 3.6 Branch
(Reporter)

Updated

8 years ago
Hardware: x86_64 → All
(Reporter)

Comment 1

8 years ago
Same behavior persists on an x86 computer I have, thus I changed the platform architecture to all.
(Reporter)

Updated

8 years ago
Keywords: conversion, helpwanted, polish, ue, uiwanted, ux-control, ux-feedback, verifyme
(Reporter)

Comment 2

8 years ago
Explanation of keywords used in relation to this bug:

conversion - Considering downloads are broken off without warning, there's no reason for my friends to move away from browsers which actually do handle downloads properly.

helpwanted - I have no coding experience of the level required to fix firefox.

polish - Fixing the download window so it remains open when firefox closes would probably only involve the return to code used prior to the update that created this bug.

ue - It is confusing not to be prompted when data exists within the download window whether or not firefox should close. Firefox seems to assume any data found within the download window, whether this involves currently downloading files or finished downloads, is of such low priority to the user that firefox can just up and shut down, often breaking downloads in progress.

uiwanted - Firefox support claimed the new behavior in the download window was because the download window being open was inherent to a session being open. With a session open, and no button on the download window to open a new firefox main window within the session, firefox complained that it could not start a new session as one was already running. Seems to me like a small change in the ui, in particular the addition of a button or other construct with relation to the download window would be able to fix this while still maintaining the usability of the download window seperate from the main firefox window? If not possible, a suggested workaround would simply be to have firefox check for an existing session and then prompt the session manager window to pop up when a session is already found to be active. The user can then see, within the session manager window, which session is active and decide whether to restart said session (with a new firefox main window popping up within said session), close the existing session or start a new session under a different session profile.

ux-control - See my explanation for "uiwanted". The user is left with no prompt with regards to firefox' behavior. There's no input requested from the user. Firefox assumes the user wishes to break off their downloads and/or lose any data found within the download window.

ux-feedback - See my explanation for "uiwanted" and "ux-control". The user is left with no prompt, and thusly no feedback is given about the current state of the downloads initiated by the user, nor the state of the download window in general. It just gets killed upon firefox exit as if it's not important.

verifyme - Verified on Gentoo Linux x86 & x86_64. Needs verification on other architectures and OS.

Comment 3

7 years ago
This behavior was introduced in bug 544356
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Keywords: conversion, helpwanted, polish, ue, uiwanted, ux-control, ux-userfeedback, verifyme
Resolution: --- → INVALID
(Reporter)

Comment 4

7 years ago
Bug persists. Regardless of where it was introduced.

Still unconfirmed by way of needing verification on other architectures and OS.
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
This was an intentional decision per bug 544356.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago7 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.