Can not install an XPI locally

RESOLVED INVALID

Status

()

RESOLVED INVALID
8 years ago
9 months ago

People

(Reporter: kinger, Unassigned)

Tracking

Trunk
x86
Windows Vista
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
Mozilla/5.0 (Windows NT 6.0; rv:2.0b5pre) Gecko/20100824 Minefield/4.0b5pre (.NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729)

When I drag in a local XPI or try via File-Open, no install is initiated.

Warning: WARN addons.manager: Failure calling web installer: [Exception... "Component returned failure code: 0x80570016 (NS_ERROR_XPC_GS_RETURNED_FAILURE) [nsIJSCID.getService]"  nsresult: "0x80570016 (NS_ERROR_XPC_GS_RETURNED_FAILURE)"  location: "JS frame :: resource://gre/modules/AddonManager.jsm :: AMI_installAddonsFromWebpage :: line 522"  data: no]
Strange, this suggests there is something wrong with the web install listener component. Does the file components/amWebInstallListener.js exist in the omni.jar file in your install?

Do you have any extensions installed that might be trying to take over extension installs?
(In reply to comment #0)
> When I drag in a local XPI or try via File-Open, no install is initiated.

As a workaround, try opening the containing folder (typing e.g. file:///C:/Documents%20and%20Settings/kinger/extensions/ — notice the forward-slashes and percent-escapes — in the location bar), then you ought to be able to install the extension by clicking its link.
(In reply to comment #2)
> (In reply to comment #0)
> > When I drag in a local XPI or try via File-Open, no install is initiated.
> 
> As a workaround, try opening the containing folder (typing e.g.
> file:///C:/Documents%20and%20Settings/kinger/extensions/ — notice the
> forward-slashes and percent-escapes — in the location bar), then you ought to
> be able to install the extension by clicking its link.

Are you saying that you are seeing the same problem?
(In reply to comment #3)
[...]
> Are you saying that you are seeing the same problem?

I'm saying that I used to... then it was fixed... but maybe not perfectly...
OTOH, clicking the link in the folder view always worked for me exactly as if I had clicked a remote link to the same XPI in a web page.

Comment 5

9 months ago
I can't reproduce this and after 7 years, assuming its not valid, if that's not the case please reopen.
Status: NEW → RESOLVED
Last Resolved: 9 months ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.