Sync setup buttons are not visible with dark GTK themes

RESOLVED DUPLICATE of bug 590805

Status

()

Firefox
Theme
--
minor
RESOLVED DUPLICATE of bug 590805
7 years ago
7 years ago

People

(Reporter: yannubuntu, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (X11; Linux i686; rv:2.0b5pre) Gecko/20100824 Minefield/4.0b5pre
Build Identifier: Mozilla/5.0 (X11; Linux i686; rv:2.0b5pre) Gecko/20100824 Minefield/4.0b5pre

see attached screenshot : Sync setup buttons text is not visible as it is dark (fixed) when the background is also dark (with dark GTK themes only, such as the default Ubuntu theme, which is the most widely used)

Reproducible: Always
Component: Menus → Theme
QA Contact: menus → theme
Version: unspecified → Trunk

Comment 1

7 years ago
Do you have the Sync extension installed as well?    A similiar thing happens with Mobile Firefox Sync in bug 589338, but that's because the extension and integrated sync cannot coexist.

Please take a look if that's true, and disable the extension if it is.  Then try the test again.   FWIW, sync extension should not be compatible with 4.0b5pre.
(Reporter)

Comment 2

7 years ago
No, I don't have any "Sync" extension. I disabled all my extensions, restarted Firefox, and the bug remains.

Please note that the background of the 2 images (that you can see on the screenshot) change according to the GTK theme I use. I think the color is the same as the upper decoration of the Gnome windows (where there are the Close/Minimize/Maximize buttons).

At the contrary, the color of the font on these 2 images is always black (changes to white when the mouse is above the image).
I am seeing exactly the same thing on Ubuntu 10.04 on the latest nightly (20100906), even with no extensions enabled. Confirming.
Status: UNCONFIRMED → NEW
blocking2.0: --- → ?
Ever confirmed: true
This was fixed in the last nightly by bug 590805.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 590805
blocking2.0: ? → ---
You need to log in before you can comment on or make changes to this bug.