Sort by Date + Grouped by Sort does not work for mail with future Date:

RESOLVED DUPLICATE of bug 478863

Status

Thunderbird
General
RESOLVED DUPLICATE of bug 478863
8 years ago
8 years ago

People

(Reporter: Sebastian Bergmann, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2.8) Gecko/20100723 Ubuntu/10.04 (lucid) Firefox/3.6.8
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.11) Gecko/20100713 Thunderbird/3.0.6

Mails with Date: from the future are sorted into a group that cannot be exanded thus making the mails unreadable.

Reproducible: Always

Steps to Reproduce:
1. Receive a mail with Date: from the future
2. Sort mails by date
3. Group mails by sort
Actual Results:  
The mail with Date: from the future is sorted into a group with an empty title.
This group with empty title cannot be expanded, the mail is not visible unless the grouping is disabled.

Expected Results:  
Not sure how the UI/UX should be for this, but the current situation is bad.
(Reporter)

Comment 1

8 years ago
Created attachment 468686 [details]
Screenshot of Thunderbird that shows the problem (mail from the future,  Sort by Date + Grouped by Sort)
(Reporter)

Comment 2

8 years ago
Created attachment 468687 [details]
Screenshot of Thunderbird that shows the same inbox but with Sort by Date + Grouped by Sort disabled
(Reporter)

Comment 3

8 years ago
Also have this problem with latest Thunderbird 3.1 on Windows.
I'm also experiencing this same issue. This also happens when the date is apparently "unknown" (i.e. shows up as 01-01-1970).

Updated

8 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 478863
You need to log in before you can comment on or make changes to this bug.