Mouseup on awesomescreen pane button after a drag results in a pressed down button state, but no action

VERIFIED FIXED

Status

--
minor
VERIFIED FIXED
8 years ago
8 years ago

People

(Reporter: aakashd, Assigned: vingtetun)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
Build id:
Mozilla/5.0 (X11; U; Linux armv71; Nokia N900; en-US; rv:2.0b4pre) Gecko/20100823 Namoroka/4.0b4pre Fennec/2.0a1pre

Steps to Reproduce:
1. Click on the url bar to open the awesome screen
2. Press and hold down on the "Bookmarks" pane button
3. Drag your finger to the "History" pane button
4. Release your finger

Actual Results:
The "History" pane and "All Pages" buttons are in a pressed down state, but I'm not switch to the pane. 

Expected Results:
Either the "History" pane button is not in a selected state or the user is moved over to that pane.
(Reporter)

Updated

8 years ago
tracking-fennec: --- → ?
(Reporter)

Comment 1

8 years ago
Ugh, the real build id is Mozilla/5.0 (Android; Linux armv71; Nokia N900; en-US; rv:2.0b5pre) Gecko/20100824 Namoroka/4.0b5pre Fennec/2.0a1pre
Created attachment 469448 [details] [diff] [review]
Patch

This rule looks like a mistake on my side...
Assignee: nobody → 21
Attachment #469448 - Flags: review?(mbrubeck)
Attachment #469448 - Flags: review?(mbrubeck) → review+
tracking-fennec: ? → 2.0b1+
http://hg.mozilla.org/mobile-browser/rev/cc46f87f3d2e
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
(Reporter)

Comment 4

8 years ago
verified FIXED on builds:
Mozilla/5.0 (X11; U; Linux armv71; Nokia N900; en-US; rv:2.0b5pre) Gecko/20100830 Namoroka/4.0b5pre Fennec/2.0a1pre

and

Mozilla/5.0 (Android; Linux armv71; Nokia N900; en-US; rv:2.0b5pre) Gecko/20100830 Namoroka/4.0b5pre Fennec/2.0a1pre
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.