Status

SeaMonkey
General
P3
critical
VERIFIED DUPLICATE of bug 41057
18 years ago
13 years ago

People

(Reporter: Dan Stromberg, Assigned: asa)

Tracking

({crash})

Trunk
x86
Linux
crash

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.75 [en] (X11; U; Linux 2.2.16-3 i686)
BuildID:    

mozilla M18 and nightly 2000-11-3 both fail to run on my machine, even if I rm
-rf ~/.mozilla, even if I mv ~/.gtkrc{,.nopers}, even if I disable libbell, even
if I disable libsafe.

strace reveals:

[pid 11234] stat("/home/mozilla-M18/package/chrome", {st_mode=S_IFDIR|0775,
st_size=4096, ...}) = 0
[pid 11234] pipe([8, 9])                = 0
[pid 11234] fcntl(8, F_GETFL)           = 0 (flags O_RDONLY)
[pid 11234] fcntl(8, F_SETFL, O_RDONLY|O_NONBLOCK) = 0
[pid 11234] fcntl(9, F_GETFL)           = 0x1 (flags O_WRONLY)
[pid 11234] fcntl(9, F_SETFL, O_WRONLY|O_NONBLOCK) = 0
[pid 11234] sched_get_priority_max(0)   = 0
[pid 11234] sched_get_priority_min(0)   = 0
[pid 11234] pipe([10, 11])              = 0
fn=0xf00, child_stack=0x80df088, flags=CLONE_SIGHAND|0x1, args=0xbfffee6c[pid
11234] clone()                     = 11236
[pid 11234] write(11, "\325z%@\5\0\0\0\0107\1@
5\27@^\2\0\0E\2\0\0\372\242\32"..., 148) = 148
[pid 11234] rt_sigprocmask(SIG_SETMASK, NULL, [RT_0], 8) = 0
[pid 11234] write(11, "@k\33@\0\0\0\0
\354\377\277\34t\31@\0\320\r\10\0\0\0\200"..., 148) = 148
[pid 11234] rt_sigprocmask(SIG_SETMASK, NULL, [RT_0], 8) = 0
[pid 11234] rt_sigsuspend([] <unfinished ...>
[pid 11234] --- SIGRT_0 (Real-time signal 0) ---

...and there it gets stuck indefinitely.

I tried to find this bug in the bug database, but the search function gave me
thousands of unrelated hits.  I waded for a while and gave up when I realized
none of the hits even seemed to include my search keywords.


Reproducible: Always
Steps to Reproduce:
1. run it on my work computer


Actual Results:  It got stuck


Expected Results:  It should have displayed a mozilla window


My computer runs a mostly-stock redhat 6.2.

If I put my .gtkrc back in place, mozilla won't hang.  It'll exit prematurely.

Comment 1

18 years ago
did you run it once as root? 
Severity: blocker → critical
Keywords: crash
(Reporter)

Comment 2

18 years ago
No, I did not run it once as root.  Should I?
(Assignee)

Comment 3

18 years ago
see bug 41057
(Reporter)

Comment 4

18 years ago
Thanks

Comment 5

18 years ago
Dan, did running once as root fix the problem?  If so, please mark this bug as 
a duplicate of bug 41057.  Thanks :)

You can also vote for 41057 if you'd like.
(Reporter)

Comment 6

18 years ago

*** This bug has been marked as a duplicate of 41057 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE
(Assignee)

Comment 7

18 years ago
Dan Stromberg, thanks for the followup.  Marking Verifed.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.