Firefox Panorama groups ignored by Aero Peak

RESOLVED DUPLICATE of bug 587440

Status

RESOLVED DUPLICATE of bug 587440
8 years ago
3 years ago

People

(Reporter: natmaster, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b5pre) Gecko/20100824 Minefield/4.0b5pre
Build Identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b5pre) Gecko/20100824 Minefield/4.0b5pre

Create a bunch of a tab groups expecting to behind to hide away some tabs while working on something out, but then you are sadly disappointed by all your millions of tabs showing up in Aero Peak. Furthmore, the order of those tabs seems very arbitrary as they are not even organized by tab group.

Reproducible: Always

Steps to Reproduce:
1. Use Windows 7
2. Create more than one tab group in Firefox Panorama
3. Activate aero peak
Actual Results:  
All tabs in every group are displayed in (seemingly) arbitrary order.

Expected Results:  
Either tab groups, or tabs from current group should be shown.

Comment 1

8 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b4) Gecko/20100818 Firefox/4.0b4 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b4) Gecko/20100818 Firefox/4.0b4 (.NET CLR 3.5.30729)

Reproducible: Always

Steps to Reproduce:
1. Use Windows 7
2. Create more than one tab group in Firefox Panorama
3. Hoover the firefox icon on the taskbar so that the tab icons open up.
4. Hoover over one of the tab icons until you get a peek of it.
5. Now you can hover the rest of the tabs and they will instantly display.

Actual Results:  
Look at the firefox tabs in the firefox window, they are no longer showing the tabs of the group you were currently in, they are showing all tabs you hoovered. It will fix it self once you switch tabs.

Expected Results:  
No tabs for other tabs should remain when you switch back to firefox.

Comment 2

8 years ago
I produced some mock-ups of how I think Aero peek should look here:
https://wiki.mozilla.org/User:Broccauley/Fixing_TabCandy
(Reporter)

Comment 3

8 years ago
(In reply to comment #2)
> I produced some mock-ups of how I think Aero peek should look here:
> https://wiki.mozilla.org/User:Broccauley/Fixing_TabCandy

Hrm. I do like the idea of having Aero Peak show TabCandy groups, instead of individual tabs. Much more logical usage. (Follows from people using multiple windows for different groups in Firefox 3)

Comment 4

8 years ago
(In reply to comment #3)
> (In reply to comment #2)
> > I produced some mock-ups of how I think Aero peek should look here:
> > https://wiki.mozilla.org/User:Broccauley/Fixing_TabCandy
> 
> Hrm. I do like the idea of having Aero Peak show TabCandy groups, instead of
> individual tabs. Much more logical usage. (Follows from people using multiple
> windows for different groups in Firefox 3)

Note though in that proposal there is no such thing as "TabCandy Groups" - only windows, but with the same Panorama interface to make this organizationinto windows easier. Hence, this doesn't "follow on" from people grouping by window in FF3 - it is the exact same behaviour and keeps things simple!

Updated

8 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 587440
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.