Rendering all discarded images in tab groups crashes firefox

RESOLVED WORKSFORME

Status

Firefox Graveyard
Panorama
P4
normal
RESOLVED WORKSFORME
7 years ago
2 years ago

People

(Reporter: The 8472, Assigned: juanb)

Tracking

unspecified
Firefox 4.0
x86
Windows 7
Dependency tree / graph

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b4) Gecko/20100818 Firefox/4.0b4
Build Identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b4) Gecko/20100818 Firefox/4.0b4

My Firefox installation generall crashes once reaching approximately 1.4GB memory usage. This crash does not go through crash reporter, it immediately triggers the "there is a problem with this program" dialog in windows 7.

I was able to solve this problem by setting
image.mem.discardable = true
image.mem.decodeondraw = true

As far as i understand it this discards drawn images in background tabs and thus saves memory, preventing firefox from crashing.


The problem with tabcandy is that it redraws all tabs to create the icons in the tab groups, which means that all images on all tabs get un-discarded, consuming memory and crashing firefox.

Reproducible: Always

Steps to Reproduce:
1. set image.mem.discardable = true and image.mem.decodeondraw = true
2. Open lots (100+) of image-heavy (many images or big images) tabs
3. open tabcandy and let it render the tab group
4. crash
(Reporter)

Updated

7 years ago
Depends on: 590674
Priority: -- → P4

Comment 1

7 years ago
Needs confirmation.
Assignee: nobody → jbecerra
reporter please provide crash report.

Comment 3

7 years ago
https://developer.mozilla.org/En/How_to_get_a_stacktrace_for_a_bug_report

we're using memory mapping for the graphics card which reduces the amount of memory available for the rest of our work which is why we crash near 1.4gb instead of 2.0gb as we used to in previous versions.

Updated

7 years ago
Blocks: 585689
Target Milestone: --- → Firefox 4.0
(Reporter)

Comment 4

7 years ago
While the underlying OOM/virtual address space issue still persists tab candy does not worsen it anymore due to changes in the session restore. (something about staged session restore *mumble mumble*)

=> marking it as resolved
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED

Updated

7 years ago
Resolution: FIXED → WORKSFORME
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.