Closed Bug 590411 Opened 12 years ago Closed 12 years ago

Sync/Weave is not included if FF is built against libxul sdk

Categories

(Firefox Build System :: General, defect)

All
Linux
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 586867

People

(Reporter: wolfiR, Unassigned)

Details

AFAIK Sync is part of the Firefox app (not xulrunner) and is enabled in browser/confvars.sh.
But then building is configured in toolkit/toolkit-tiers.mk:
ifdef MOZ_SERVICES_SYNC
tier_platform_dirs += services/crypto
tier_platform_dirs += services/sync
endif
I have just found a reference that services-sync is indeed a GRE component:
http://mxr.mozilla.org/mozilla-central/source/services/sync/Weave.js#84

The integration is inconsistent then!
I would even call it a dupe. The subject is misleading but it's about the same issue.
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
Component: Build Config → General
Product: Firefox → Firefox Build System
You need to log in before you can comment on or make changes to this bug.