Reloading about:blank increases memory consumption

RESOLVED INVALID

Status

Fennec Graveyard
General
RESOLVED INVALID
7 years ago
7 years ago

People

(Reporter: Marko Pellikka, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US) AppleWebKit/533.4 (KHTML, like Gecko) Chrome/5.0.375.126 Safari/533.4
Build Identifier: Mozilla/5.0  (X11; U; Linux i686; en-US; rv:1.9.2.8) Gecko/20100723 Namoroka/ Fennec/1.0.0

When about:blank is reloaded, memory consumption increases. This can be repeated until 7 MB more memory is consumed (maybe even longer).

Reproducible: Always

Steps to Reproduce:
1. Start Fennec
2. Go to URL about:blank
3. Keep reloading page using reload button
4. Observe Fennec memory consumption getting higher (for example with top)
Actual Results:  
Memory consumption in the beginning according to top
RES: 34m
VIRT: 118m

Memory consumption after many reloads:
RES: 31m
VIRT: 124m

Expected Results:  
Reloading page with practically no content, shouldn't notably increase memory consumption.
tracking-fennec: --- → ?
tracking-fennec: ? → 2.0+

Updated

7 years ago
Assignee: nobody → doug.turner
(Reporter)

Comment 1

7 years ago
Correction to results:

Memory consumption in the beginning according to top
RES: 34m
VIRT: 118m

Memory consumption after many reloads:
RES: 41m
VIRT: 124m

7 MB difference can be seen between reserved memory count. Also virtual memory consumption is getting higher.

Comment 2

7 years ago
basically we tear down and bring up a new window each time.  these are cached and we hold onto some number of them until they are GC'ed.  We probably can do thing to prevent reloading of about:blank / about:home.  We should also look to see why we hold so many windows before GC'ing them.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 3

7 years ago
Sounds like this is not a bug, but a way how browser works. Can those things be tuned from about:config settings?

Updated

7 years ago
Assignee: doug.turner → nobody

Comment 4

7 years ago
7MB difference is likely due to memory fragmentation, GC, etc. If it stops at 7MB, there is nothing to worry about. If it can rise uncontrollably, please reopen this bug.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.