Closed Bug 590465 Opened 10 years ago Closed 10 years ago

start page option Blank Page changed after restart

Categories

(Firefox for Android Graveyard :: General, defect, minor)

ARM
All
defect
Not set
minor

Tracking

(fennec2.0b1+)

VERIFIED FIXED
Tracking Status
fennec 2.0b1+ ---

People

(Reporter: ioana.chiorean, Assigned: mfinkle)

References

Details

Attachments

(1 file, 1 obsolete file)

User-Agent:       Mozilla/5.0 (Windows NT 6.1; rv:2.0b5pre) Gecko/20100823 Minefield/4.0b5pre
Build Identifier: Mozilla /5.0 (Android;Linux armv7l; rv:2.0b5pre) Gecko/20100824 Namoroka/4.0b5pre Fennec /2.0a1pre

Changing the setting Start Page in Preference to Blank Page and restarting Fennec will open a blank page at start up but the option in preference will be set on Fennec Start. 

Reproducible: Always

Steps to Reproduce:
1.Change in Preference the setting Start Page to Blank Page
2.Restart Fennec
3.Enter the Preference menu
4.Look at the setting Start Page
Actual Results:  
The Start Page is set to Fennec Start

Expected Results:  
The Start Page should be set to Blank Page

For Use current Page 
-> the setting doesn't came to the default value of Fennec start. 
-> after Restart of Fennec the setting is Custom Page as expected
Reproducible also with Nokia N900
Build Identifier: Mozilla /5.0 (X11;Linux armv7l; rv:2.0b5pre)
Gecko/20100824 Namoroka/4.0b5pre Fennec /2.0a1pre
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows 7 → All
Hardware: x86 → ARM
For the above scenario browser.startup.homepage in about:config is set to blank page which is correct. Only in options/Preferences appears the value Fennec Start
Attached patch patch (obsolete) — Splinter Review
We were using "DOMContentLoaded" to know when the first page loaded. Then we delay init some code - PreferenceView is one of them.

For "about:blank" the "DOMContentLoaded" event/message is not fired. Changing to "pageshow" makes it all work again.
Assignee: nobody → mark.finkle
Attachment #469049 - Flags: review?(21)
pushed:
http://hg.mozilla.org/mobile-browser/rev/a06f094032da
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
I had to back this out for a Ts regression:

Regression: Ts increase 26.5% on Nokia n900 mobile
    Previous results:
        7890.11 from build 20100825074423 of revision efcd1f5cd192 at 2010-08-25 07:57:38 on n900-033 run # 0
    New results:
        9984.22 from build 20100825075612 of revision a06f094032da at 2010-08-25 08:11:29 on n900-019 run # 0
    http://mzl.la/cGofQ0
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Problem:
1. We use DOMContentLoaded messages to trigger the delay load of extra code
2. DOMContentLoaded messages ignore about:blank
3. Blank start page is about:blank
4. pageshow does not ignore about:blank
5. All pages load about:blank first, then the real page

We really need to fix #5, then stop doing #2
tracking-fennec: --- → ?
tracking-fennec: ? → 2.0b1+
Attached patch patch 2Splinter Review
The previous patch caused a Ts regression because setting a start page to "blank" means we use "about:blank" and we had needed to switch the delay load trigger away from "DOMContentLoaded" because it ignores "about:blank" so it never fired.

This patch makes new alias for "about:blank", called "about:empty" and uses it for the blank start page. We can now keep "DOMContentLoaded" as the trigger. The delayed load is fired, and Ts should not be regressed.

I added "about:empty" to our list of empty URIs and also removed a left-over about:sync-tabs reference.

We might be able to use about:empty in tests too, and not need to worry about about:blank so much.
Attachment #469049 - Attachment is obsolete: true
Attachment #470245 - Flags: review?(21)
pushed:
http://hg.mozilla.org/mobile-browser/rev/4fb363178ae2
Status: REOPENED → RESOLVED
Closed: 10 years ago10 years ago
Resolution: --- → FIXED
Verified on Build:
Mozilla /5.0 (Android;Linux armv7l; rv:2.0b6pre)
Gecko/20100903 Firefox/4.0b6pre Fennec /2.0b1pre

and

Mozilla /5.0 (Maemo;Linux armv7l; rv:2.0b6pre)
Gecko/20100903 Firefox/4.0b6pre Fennec /2.0b1pre
Status: RESOLVED → VERIFIED
Depends on: 617739
You need to log in before you can comment on or make changes to this bug.