Closed Bug 590477 Opened 11 years ago Closed 11 years ago

XML parsing error when opening a prompt

Categories

(Firefox for Android Graveyard :: General, defect)

ARM
Maemo
defect
Not set
major

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: ahoza, Unassigned)

Details

Attachments

(1 file)

Attached image Screenshot
BuildID: Mozilla/5.0 (X11; Linux armv7l; rv:2.0b5pre) Gecko/20100825
Namoroka/4.0b5pre Fennec/2.0a1pre
Device: Nokia N900


Steps to reproduce:

1. Open Fennec.
2. Access 2 pages in different tabs
3. Close Fennec using "X" button

Expected results:
Confirmation close dialog is displayed

Actual results:
XML parsing error message is displayed (see attached screenshot). Need to restart device afterwards in order to use it
Are you using a non-English language?
No. It does that with English (I've tried it with another language and the behavior is the same only that I get the error message localized)

Beside the above behevior, which reproduces all the time, I've got the XML parsing error while opening a new tab (this happened only a few times; don't know steps to reproduce it)

I've put wrong build ID above. buildID is: Mozilla/5.0 (X11; Linux armv7l; rv:2.0b5pre) Gecko/20100825 Namoroka/4.0b5pre Fennec/2.0b1pre
I'm seeing this on builds:
Mozilla/5.0 (X11; U; Linux armv71; Nokia N900; en-US; rv:2.0b5pre) Gecko/20100825 Namoroka/4.0b5pre Fennec/2.0a1pre

and

Mozilla/5.0 (Android; Linux armv71; Nokia N900; en-US; rv:2.0b5pre) Gecko/20100825 Namoroka/4.0b5pre Fennec/2.0a1pre


with the following steps to reproduce:

1. Go to www.espn.com in one tab
2. Open a new tab and go to lassey.us/proto.html
3. Click on "Call me"
tracking-fennec: --- → ?
Turns out we were broke by a platform patch from bug 546857 (part 6). I'll followup with Jonas Sicking about it.

http://hg.mozilla.org/mozilla-central/rev/cec16a1741fb
Summary: XML parsing error when trying to close browser. → XML parsing error when opening a prompt
Should be fixed by bug 546857
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
verified FIXED On builds:

Mozilla/5.0 (X11; U; Linux armv71; Nokia N900; en-US; rv:2.0b5pre) Gecko/20100827 Namoroka/4.0b5pre Fennec/2.0a1pre

and

Mozilla/5.0 (Android; Linux armv71; Nokia N900; en-US; rv:2.0b5pre) Gecko/20100827 Namoroka/4.0b5pre Fennec/2.0a1pre
Status: RESOLVED → VERIFIED
tracking-fennec: ? → ---
You need to log in before you can comment on or make changes to this bug.