Firefox Sync Needs an Online (WWW) Interface

RESOLVED DUPLICATE of bug 542506

Status

--
enhancement
RESOLVED DUPLICATE of bug 542506
8 years ago
6 years ago

People

(Reporter: spamcop, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
[Sorry for choosing the general component, but where is the "Sync" component? Please update component appropriately. I also don't know if this qualifies as a Fx enhancement at all, but I really don't know the correct category for such a request]

Fx Sync in 4.0 Beta 4 is basically just offering functionality that exists for ages as extensions (e.g. Xmarks, formally Foxmarks, LastPass, and many other), however, it misses a very important feature you find at all those extensions and without that feature, Fx Sync is of so limited use IMHO, that it should stay an extension and not become a core part of Fx 4.0: All those services allow you to access your bookmarks, history or passwords via a WEB interface.

Of what use is Fx Sync to me, if it has all my important servers stored on Mozilla servers, but I'm not at any computer of mine, there is no copy of Fx on that machine, I cannot or must not install Fx (or any other software) on that machine either, how do I access the data then? And no, I have no iPhone! With all the extensions above, I can go to their web page, log in, and access the info from everywhere in the world, as long as I have access to the Internet and any browser in front of me. Data stored on Mozilla servers, that I might not be able to access when I urgently need them are pretty much the most useless thing in the world IMHO.

Comment 1

8 years ago
http://mozillalabs.com/sync/2010/08/24/sync-in-firefox-4-beta/

Actually, the data is encrypted, and Mozilla can't know what's inside. That's on purpose. This means that it can't show you the bookmarks, history or passwords in a webinterface. Maybe you can supply the secret phrase to decrypt the data, but I wouldn't trust anyone (including Mozilla) with the key.
(Reporter)

Comment 2

8 years ago
In case of LastPass, the passwords are also encrypted before they ever leave the computer... even though they are later on transported over HTTPS (so the transport is safe anyway), but they are encrypted on the local computer, because they are stored encrypted on the LP servers, thus not even LP can access the data.

Still they offer a web interface. This works by having JS code on their web page, that prompts you for the password, downloads the encrypted data via AJAX and decrypts it dynamically in computer memory (all decryption happens within JS code running on your local machine).

I fail to see why this is would not be possible with Fx Sync.

Comment 3

6 years ago
Technically possible. But will require a lot of work.
Component: General → Firefox Sync: Other Clients
Product: Firefox → Mozilla Services
QA Contact: general → other.clients
Version: Trunk → unspecified

Updated

6 years ago
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 542506
You need to log in before you can comment on or make changes to this bug.