Closed Bug 590517 Opened 9 years ago Closed 9 years ago

Add "Open in New Tab" menu item to Awesome Screen

Categories

(Firefox for Android Graveyard :: General, defect)

defect
Not set

Tracking

(fennec2.0b2+)

VERIFIED FIXED
Tracking Status
fennec 2.0b2+ ---

People

(Reporter: isandu, Assigned: vingtetun)

References

Details

Attachments

(1 file, 1 obsolete file)

This is a bug to add "Open in New Tab" menu item in the context menu of the Awesome Screen items.
Agreed
Assignee: nobody → 21
I also want to add more items to the (future) context menu of the awesome panel (like "Forget this domain" or "Share")
OS: Android → All
Hardware: ARM → All
tracking-fennec: --- → ?
Attached patch Patch (obsolete) — Splinter Review
The attached patch add "Open In New Tab" and "Share Link" as context items.
The awesome panel is not closed when we open a new tab (I have a doubt on the right behavior here, I've moved the "new tab popup" to be above the awesome panel to have a feedback)
Attachment #469487 - Flags: review?(mark.finkle)
tracking-fennec: ? → 2.0b2+
Comment on attachment 469487 [details] [diff] [review]
Patch

Patch looks OK, but I think we'll want to close the awesomescreen when opening a new tab. Sharing and editing (for bookmarks) sound like good cases for leaving the awesomscreen open.

Madhava -  thoughts?
Attachment #469487 - Flags: review?(mark.finkle) → review+
Attached patch PatchSplinter Review
This patch add a small fix found while testing.

For the case where we want or not to close the Awesome Panel I've tried to do it but since "Open In New Tab" does not put the tab into the foreground this give a strange effect.

The website menu is not doing it too (moving the tab to the foreground) since this is the same code path.
(But) I realize that the expectation are probably different when doing this on a website or searching into the Awesome Panel.

Irina, what are doing the other browsers?
Attachment #469487 - Attachment is obsolete: true
Vivien - adding a "Forget this Page" or "Forget this Site" would be a really useful thing.

For this one - open in new tab - what is the anticipated use-case for doing this from the awesomescreen?  A user taps on the title to go somewhere and, on the way to finding the thing he or she wants, notices something else that he or she would like to see later?
(In reply to comment #6)

> For this one - open in new tab - what is the anticipated use-case for doing
> this from the awesomescreen?  A user taps on the title to go somewhere and, on
> the way to finding the thing he or she wants, notices something else that he or
> she would like to see later?

The user realizes that he does not want to clobber the existing tab content, iirc.
I do that when I am in the middle of reading an article but that reminds me of something I want to check after finishing reading and I open a new tab in the background in order not to forget.
What's wrong with the current flow of opening a new tab (which opens the awesome screen) loading your new page and then returning to the original tab?
(In reply to comment #9)
> What's wrong with the current flow of opening a new tab (which opens the
> awesome screen) loading your new page and then returning to the original tab?

You might change your mind.  Also, opening the awesomescreen directly (by pressing the Android "Search" button, or tapping the urlbar if it is visible) is often more convenient than panning to show the new tab button - especially if you are zoomed in and might need to pan a lot.
for the question raised in an etherpad - we shouldn't close the awesomescreen after a user opens something in a new tab.  This mirrors the behavior of opening a link in a new tab, which leaves the user where he or she is.
Comment on attachment 469705 [details] [diff] [review]
Patch

Looking at Madhava's comment the behavior in this patch should be good. I'm asking review again because of the small changes and to ensure I have well understood the comment :)
Attachment #469705 - Flags: review?(mark.finkle)
Comment on attachment 469705 [details] [diff] [review]
Patch

Seems like you have the design as Madhava wanted
Attachment #469705 - Flags: review?(mark.finkle) → review+
http://hg.mozilla.org/mobile-browser/rev/4ac74951887d
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Verified on :

Build: Mozilla /5.0 (Android;Linux armv7l;rv:2.0b6pre)Gecko/20100909
Firefox/4.0b6pre Fennec /2.0b1pre
Status: RESOLVED → VERIFIED
Duplicate of this bug: 596609
You need to log in before you can comment on or make changes to this bug.