images served through cgi-bin script do not appear in browser

VERIFIED DUPLICATE of bug 54959

Status

()

Core
Networking: HTTP
P3
normal
VERIFIED DUPLICATE of bug 54959
18 years ago
16 years ago

People

(Reporter: em, Assigned: Gagan)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.74 [en] (X11; U; Linux 2.2.16-3 i686)
BuildID:    2000101015

Images at <http://www.ericharsbarger.com> are served through a cgi-bin script.
When viewed through Mozilla, none of the images are viewable and HTTP headers
are displayed as part of the text in the browser (ex: "HTTP 200 Document follows
Date: Fri, 03 Nov 2000 23:09:09 GMT Server: NCSA/1.5.2 Last-modified: Sun, 29
Oct 2000 02:14:39 GMT Content-type: text/html Content-length: 629")

Reproducible: Always
Steps to Reproduce:
1.Start Mozilla and enter the URL <http://www.ericharshbarger.com>
2.
3.

Actual Results:  HTTP header info appears at the top of the browser window.
No graphic appears and eventually a timeout error dialog appears	

Expected Results:  Displayed the referenced image.

Comment 1

18 years ago
confirmed with mozilla trunk build 110304 on NT. over to networking.
Assignee: asa → gagan
Status: UNCONFIRMED → NEW
Component: Browser-General → Networking
Ever confirmed: true
QA Contact: doronr → tever

Comment 2

18 years ago
This server is running (long dead) NCSA 1.5.2, and this appears to be a bug in
their HTTP/1.0 implementation (it doesn't know HTTP/1.1)
If the user sets their browser HTTP version (in Preferences/Debug/Networking) to
1.0 instead of 1.1 it will allow them to use this site, but they may experience
reduced performance on other sites.

Here's what www.ericharshbarger.com says when Mozilla speaks HTTP/1.0:
HTTP/1.0 200 Document follows
And here's what it says when Mozilla speaks HTTP/1.1:
HTTP 200 Document follows

The latter is clearly wrong according to the spec. for both HTTP/1.0 and
HTTP/1.1. Hope this helps someone determine whether/ how Mozilla should try to
cope with this broken server. NS 4x worked because it only spoke HTTP/1.0

Comment 3

18 years ago

*** This bug has been marked as a duplicate of 54959 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Updated

16 years ago
Component: Networking → Networking: HTTP

Comment 4

16 years ago
Verified duplicate.
Status: RESOLVED → VERIFIED
QA Contact: tever → junruh
You need to log in before you can comment on or make changes to this bug.