Deselecting optional components in SeaMonkey installer does not work

RESOLVED FIXED

Status

SeaMonkey
Installer
--
major
RESOLVED FIXED
7 years ago
7 years ago

People

(Reporter: Peter B. Shalimoff, Assigned: mcsmurf)

Tracking

({regression})

Trunk
x86
Windows Server 2003
regression

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 2 obsolete attachments)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows NT 5.2; rv:2.0b4pre) Gecko/20100817 SeaMonkey/2.1a3
Build Identifier: Mozilla/5.0 (Windows NT 5.2; rv:2.0b4pre) Gecko/20100817 SeaMonkey/2.1a3

Installer ignores custom installation options and installs Chatzilla whether its checkbox is checked or not.

Reproducible: Always

Steps to Reproduce:
1. Start the installer.
2. Select Custom installation type.
3. Uncheck the "Chatzilla" checkbox.

Actual Results:  
Chatzilla is installed.


Expected Results:  
Chatzilla must not be installed.
CCing Frank, he should know most about the installer.
(Assignee)

Comment 2

7 years ago
This could be fall-out from Bug 556644, the core\ folder in the installer also includes the extensions\ folder. Normally only the optional\ folder should include the extensions\ folder (as all the extensions can be unchecked when using the custom installation mode). Everything in the core\ folder gets copied to SeaMonkey program folder so that is why deselecting components no longer works.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Chatzilla is always installed → Deselecting optional components in SeaMonkey installer does not work
(Assignee)

Updated

7 years ago
Blocks: 556644

Comment 3

7 years ago
Created attachment 471209 [details] [diff] [review]
Untested patch
(Assignee)

Comment 4

7 years ago
Comment on attachment 471209 [details] [diff] [review]
Untested patch

Patch seems to work fine, I tested it by creating a SeaMonkey installer and deselecting optional components. I also checked the temporary folder into which the installer files get extracted to, the core\extensions\ folder only contains the SeaMonkey themes, which are not optional components.
(Assignee)

Comment 5

7 years ago
Created attachment 478423 [details] [diff] [review]
Patch

Actually Attachment 471209 [details] [diff] did not work fine, I forgot to test running SeaMonkey itself..
Here is a new approach: This one removes all files from installer-stage/core/ which are also present in installer-stage/optional/.
Assignee: installer → bugzilla
Attachment #471209 - Attachment is obsolete: true
Attachment #478423 - Flags: review?
(Assignee)

Updated

7 years ago
Attachment #478423 - Flags: review? → review?(khuey)
Severity: normal → major
Keywords: regression
Version: unspecified → Trunk
(Assignee)

Comment 6

7 years ago
Created attachment 480418 [details] [diff] [review]
Patch

This one is better, it avoids the warning because of the dot directory that cannot be removed (as the first line in the find output with the old patch was "." for the current directory).
Attachment #478423 - Attachment is obsolete: true
Attachment #480418 - Flags: review?
Attachment #478423 - Flags: review?(khuey)
(Assignee)

Updated

7 years ago
Attachment #480418 - Flags: review? → review?(khuey)
Comment on attachment 480418 [details] [diff] [review]
Patch

r=me
Attachment #480418 - Flags: review?(khuey) → review+
Fwiw, I think this qualifies as NPOTB because Firefox has no optional components.  Please test it on try though to make sure it doesn't blow anything up.
(Assignee)

Comment 9

7 years ago
Pushed to try, worked fine, then pushed to m-c: http://hg.mozilla.org/mozilla-central/rev/1951afcefd05
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.