Very slow rendering of animation

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
8 years ago
3 months ago

People

(Reporter: me, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; ru; rv:1.9.2.8) Gecko/20100723 Ubuntu/10.04 (lucid) Firefox/3.6.8
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; ru; rv:1.9.2.8) Gecko/20100723 Ubuntu/10.04 (lucid) Firefox/3.6.8

Extreamly laggy and slow animation if layer contains a some large images.

Reproducible: Always

Steps to Reproduce:
1. Go to http://sontan.name/uploads/projects/far7/ff/game.html
2. On left click activates an animation
3. On dblclick creates some large images

Actual Results:  
Animation after creation is extreamly slow

Expected Results:  
In Chrome it works smoothly :) In new ff4b4 performance has regressed even more.
Looks about the same to me in Chrome and Firefox on Mac.  So likely Linux-specific (and also likely driver-specific).
OS: All → Linux

Comment 2

8 years ago
Confirmed for win xp sp3. Very large usage of processor time in 3.6.8 but smoothly sometimes (rare), very laggy in 4.0b4 (permanent). Smooth animation in Chrome.

Comment 3

8 years ago
Looks like same case as for 556665.
Kuryanovich: can you give some info on your graphics drivers, please?
The output from "glxinfo | grep renderer" might be enough.
(In reply to comment #3)
> Looks like same case as for 556665.

Thanks Yury, let's keep this bug for Linux and bug 556665 for MS XP.
FWIW, here Chrome uses nearly twice as much cpu as Firefox (as the X server is quite busy with Chrome but not Firefox).
"glxinfo | grep OpenGL\ version" might be necessary too.
(Reporter)

Comment 8

8 years ago
$ glxinfo | grep renderer
OpenGL renderer string: GeForce 9500 GT/PCI/SSE2

$ glxinfo | grep OpenGL\ version
OpenGL version string: 2.1.2 NVIDIA 173.14.27
Hello Egor, your nvidia driver is quite old.  I saw similar slowndowns in image compositing on other pages with the version 185 driver, and yours is 173.

The slowdowns went away when I upgraded to 10.4 and nvidia driver version 195.  On my machine

$ glxinfo | grep renderer
OpenGL renderer string: GeForce GT 220/PCI/SSE2
$ glxinfo | grep OpenGL\ version
OpenGL version string: 3.2.0 NVIDIA 195.36.24

the animation looks about the same in FF4 as in Chrome 5.

Can you try upgrading your nvidia driver to version 195 and report back?
My system information:

Mozilla/5.0 (X11; Linux x86_64; rv:11.0a1) Gecko/20111113 Firefox/11.0a1
OpenGL renderer string: Quadro 1000M/PCI/SSE2
OpenGL version string: 4.1.0 NVIDIA 270.41.06

I am unable to reproduce this bug. Since it's quite old, and cjones has indicated that it could be related to a driver issue, I'm closing this bug as WFM. If I'm mistaken, please accept my apologies and reopen.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME

Updated

3 months ago
Product: Core → Core Graveyard

Updated

3 months ago
Product: Core Graveyard → Core
You need to log in before you can comment on or make changes to this bug.