Last Comment Bug 590665 - Panels such as those of the Inspector jump around when dragged across multiple monitors
: Panels such as those of the Inspector jump around when dragged across multipl...
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: XP Toolkit/Widgets: XUL (show other bugs)
: Trunk
: All All
: -- normal (vote)
: ---
Assigned To: Neil Deakin (away until Oct 3)
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-25 13:07 PDT by Neil Deakin (away until Oct 3)
Modified: 2011-04-13 11:27 PDT (History)
3 users (show)
enndeakin: in‑testsuite+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
-


Attachments
fix (8.11 KB, patch)
2010-08-25 13:07 PDT, Neil Deakin (away until Oct 3)
roc: review+
Details | Diff | Splinter Review

Description Neil Deakin (away until Oct 3) 2010-08-25 13:07:57 PDT
Created attachment 469153 [details] [diff] [review]
fix

This is because panels are constrained to the area of the screen they are on, so jump to fit when crossing over.

Instead, when moving a popup, don't constrain or flip a popup.
Comment 1 Rob Campbell [:rc] (:robcee) 2010-08-26 04:24:32 PDT
haven't tested this on windows but presumably the behavior's the same there. Thanks for filing!
Comment 2 Rob Campbell [:rc] (:robcee) 2010-09-01 10:09:31 PDT
this is a usability improvement. Should this block?
Comment 3 Neil Deakin (away until Oct 3) 2010-09-02 06:59:23 PDT
Comment on attachment 469153 [details] [diff] [review]
fix

This patch skips the block where we constrain and flip the panel to fit on the screen when the panel is being moved. There might be specific cases where someone does want this behaviour, for instance, when popup.moveTo is called directly but I can add that in a followup bug.
Comment 4 Dietrich Ayala (:dietrich) 2010-09-07 06:55:27 PDT
Not going to hold the release for this change. Would definitely consider approval if the patch is safe and tested.
Comment 5 Neil Deakin (away until Oct 3) 2011-04-13 11:27:16 PDT
http://hg.mozilla.org/mozilla-central/rev/3de085749863

Note You need to log in before you can comment on or make changes to this bug.