Last Comment Bug 590714 - Move Bookmarks dialog broken
: Move Bookmarks dialog broken
Status: RESOLVED FIXED
:
Product: SeaMonkey
Classification: Client Software
Component: Bookmarks & History (show other bugs)
: Trunk
: All All
: -- normal (vote)
: seamonkey2.1b1
Assigned To: Robert Kaiser (not working on stability any more)
:
Mentors:
Depends on:
Blocks: SMPlacesBMarks
  Show dependency treegraph
 
Reported: 2010-08-25 14:37 PDT by Peter B. Shalimoff
Modified: 2010-09-28 05:40 PDT (History)
8 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
final+


Attachments
Screenshot: cfdlg.png (31.54 KB, image/png)
2010-08-25 14:39 PDT, Peter B. Shalimoff
no flags Details
Screenshot: cfdlg.ok_assert.png (5.15 KB, image/png)
2010-08-25 14:42 PDT, Peter B. Shalimoff
no flags Details
fix it! (992 bytes, patch)
2010-09-25 09:01 PDT, Robert Kaiser (not working on stability any more)
iann_bugzilla: review+
Details | Diff | Review

Description Peter B. Shalimoff 2010-08-25 14:37:23 PDT
User-Agent:       Mozilla/5.0 (Windows NT 5.2; rv:2.0b4pre) Gecko/20100817 SeaMonkey/2.1a3
Build Identifier: Mozilla/5.0 (Windows NT 5.2; rv:2.0b4pre) Gecko/20100817 SeaMonkey/2.1a3

The "Choose Folder" seems to be broken:
1) It doesn't display the existing folders.
2) Clicking its "New Folder" button does nothing visible (and there are no errors in the Error Console) - see cfdlg.png screenshot.
3) Clicking its "OK" buttons results in an assertion failure (see cfdlg.ok_assert.png screenshot):
   ASSERT: selectedNode must be set in a single-selection tree with initial selection set
   Stack Trace: 
   0:MBD_onOK([object Event])
   1:anonymous([object Event])
   2:_fireButtonEvent(accept)
   3:_doButtonCommand(accept)
   4:_handleButtonCommand([object XULCommandEvent])


Reproducible: Always

Steps to Reproduce:
1. Open Bookmarks Manager.
2. Select (hilight) a bookmark.
3. Select "Edit -> Move..." from the menu.
4. Click the "New Folder" or the "OK" button.

Actual Results:  
See the Details.


Expected Results:  
The dialog should display the existing folders.
Clicking the "New Folder" should open a folder creation dialog.
Clicking the "OK" button should, um, just work like an ordinary OK button - close the dialog and apply any changes made. :)
Comment 1 Peter B. Shalimoff 2010-08-25 14:39:26 PDT
Created attachment 469195 [details]
Screenshot: cfdlg.png

Show an empty "Choose Folder" dialog and Error Console with no errors after clicking the "New Folder" button.
Comment 2 Peter B. Shalimoff 2010-08-25 14:41:00 PDT
Comment on attachment 469195 [details]
Screenshot: cfdlg.png

Show an empty "Choose Folder" dialog and Error Console with no errors after clicking the "New Folder" button.
Comment 3 Peter B. Shalimoff 2010-08-25 14:42:56 PDT
Created attachment 469198 [details]
Screenshot: cfdlg.ok_assert.png

Shows an assertion failure after clicking the "OK" button.
Comment 4 Peter B. Shalimoff 2010-08-25 14:43:13 PDT
Comment on attachment 469198 [details]
Screenshot: cfdlg.ok_assert.png

Shows an assertion failure after clicking the "OK" button.
Comment 5 Peter B. Shalimoff 2010-08-25 14:46:08 PDT
Sorry for the dup comments - I misunderstood the "Comment" text field in the attachment creation form.
Comment 6 lenochod 2010-08-26 07:26:21 PDT
Build identifier: Mozilla/5.0 (X11; Linux x86_64; rv:2.0b5pre) Gecko/20100826 SeaMonkey/2.1b1pre

I created a new profile and the error still appears. I didn't import new bookmarks.

When I click OK, Linux command line display:

[root@venuse seamonkey]#   /usr/local/seamonkey/2_1_x_Eng/seamonkey -no-remote -P 2.1
ASSERT: selectedNode must be set in a single-selection tree with initial selection set

After the closing of all windows Bookmark Manager Error Console display:

Error: An error occurred updating the cmd_selectAll command: [Exception... "'[JavaScript Error: "this._view.result is null" {file: "chrome://communicator/content/places/controller.js" line: 181}]' when calling method: [nsIController::isCommandEnabled]"  nsresult: "0x80570021 (NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS)"  location: "JS frame :: chrome://global/content/globalOverlay.js :: goUpdateCommand :: line 80"  data: yes]
Source File: chrome://global/content/globalOverlay.js
Line: 86
Comment 7 Bruno 'Aqualon' Escherl 2010-08-27 06:53:30 PDT
Could reproduce it with Mozilla/5.0 (X11; Linux x86_64; rv:2.0b5pre) Gecko/20100827 SeaMonkey/2.1b1pre

I get also a warning opening the move bookmark dialog, but don't know if it's related to this bug:

WARNING: Context has no global.: file <path>/comm-central/mozilla/dom/base/nsJSEnvironment.cpp, line 2518
Comment 8 Justin Wood (:Callek) 2010-09-07 20:38:00 PDT
(In reply to comment #7)
> WARNING: Context has no global.: file
> <path>/comm-central/mozilla/dom/base/nsJSEnvironment.cpp, line 2518

That is usually the sign of a much larger problem...

Have either of you tested on an optimized build, and can you test with the newest nightly?

Do either of you have access to a non-linux machine and can verify if it happens there too? [If not I'll check on windows later]
Comment 9 lenochod 2010-09-08 02:43:30 PDT
Mozilla/5.0 (Windows NT 5.1; rv:2.0b6pre) Gecko/20100907 SeaMonkey/2.1b1pre

When I open Bookmark Manager, Error Console display:

CoCreateInstance() FAILED.

(In reply to comment #0)
> The "Choose Folder" seems to be broken:
> 1) It doesn't display the existing folders.
> 2) Clicking its "New Folder" button does nothing visible (and there are no
> errors in the Error Console) - see cfdlg.png screenshot.
> 3) Clicking its "OK" buttons results in an assertion failure (see
> cfdlg.ok_assert.png screenshot):
>    ASSERT: selectedNode must be set in a single-selection tree with initial
> selection set
>    Stack Trace: 
>    0:MBD_onOK([object Event])
>    1:anonymous([object Event])
>    2:_fireButtonEvent(accept)
>    3:_doButtonCommand(accept)
>    4:_handleButtonCommand([object XULCommandEvent])

It is diplay too.
Comment 10 Bruno 'Aqualon' Escherl 2010-09-08 02:57:27 PDT
(In reply to comment #9)

> When I open Bookmark Manager, Error Console display:
> 
> CoCreateInstance() FAILED.

I also get this on every occasion I use a menu, so probably not related to the problem here.
Comment 11 lenochod 2010-09-08 03:44:06 PDT
Aqualon, have I make stacktrace with WinDbg?
Comment 12 lenochod 2010-09-13 04:57:05 PDT
(In reply to comment #6)
> After the closing of all windows Bookmark Manager Error Console display:
> 
> Error: An error occurred updating the cmd_selectAll command: [Exception...
> "'[JavaScript Error: "this._view.result is null" {file:
> "chrome://communicator/content/places/controller.js" line: 181}]' when calling
> method: [nsIController::isCommandEnabled]"  nsresult: "0x80570021
> (NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS)"  location: "JS frame ::
> chrome://global/content/globalOverlay.js :: goUpdateCommand :: line 80"  data:
> yes]
> Source File: chrome://global/content/globalOverlay.js
> Line: 86

Mozilla/5.0 (Windows NT 5.1; rv:2.0b6pre) Gecko/20100912 Firefox/4.0b6pre SeaMonkey/2.1b1pre

It display only when didn't open Error console window during the test Bookmark Manager.
Comment 13 XtC4UaLL [:xtc4uall] 2010-09-19 15:32:09 PDT
(In reply to comment #6)
> Error: An error occurred updating the cmd_selectAll command: [Exception...
> "'[JavaScript Error: "this._view.result is null" {file:
> "chrome://communicator/content/places/controller.js" line: 181}]' when calling
> method: [nsIController::isCommandEnabled]"  nsresult: "0x80570021
> (NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS)"  location: "JS frame ::
> chrome://global/content/globalOverlay.js :: goUpdateCommand :: line 80"  data:
> yes]
> Source File: chrome://global/content/globalOverlay.js
> Line: 86

FWIW, i get the same in Mozilla/5.0 (Windows NT 5.1; rv:2.0b7pre) Gecko/20100919 Firefox/4.0b7pre, of course for a different File:
"chrome://browser/content/places/controller.js" line: 179
Bug in the shared Places Code?
Comment 14 Robert Kaiser (not working on stability any more) 2010-09-25 08:31:58 PDT
(In reply to comment #13)
> Bug in the shared Places Code?

At least that's the same code. Please file a bug on Firefox bookmarks and history for that, though, and note it there, as we'll need patches on both sides, reviewed by both teams, in any case.

Does the Move Bookmarks window work in Firefox trunk?
Comment 15 Robert Kaiser (not working on stability any more) 2010-09-25 09:01:37 PDT
Created attachment 478538 [details] [diff] [review]
fix it!

It might be better to link the correct CSS file to get the XBL applied...

Addressing review to Ian as he reviewed the original patch. ;-)
Comment 16 Robert Kaiser (not working on stability any more) 2010-09-25 14:06:06 PDT
Pushed as http://hg.mozilla.org/comm-central/rev/4f719059999e
Comment 17 lenochod 2010-09-26 03:59:07 PDT
Mozilla/5.0 (Windows NT 5.1; rv:2.0b7pre) Gecko/20100926 Firefox/4.0b7pre SeaMonkey/2.1b1pre

It works fine now
Comment 18 neil@parkwaycc.co.uk 2010-09-28 05:40:11 PDT
(In reply to comment #9)
> When I open Bookmark Manager, Error Console display:
> 
> CoCreateInstance() FAILED.
It's trying to detect nVidia 3D Vision. See bug 598328.

Note You need to log in before you can comment on or make changes to this bug.