Closed Bug 590805 Opened 10 years ago Closed 10 years ago

Sync UI: Revamp setup wizard

Categories

(Firefox :: General, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED
Tracking Status
blocking2.0 --- beta7+

People

(Reporter: philikon, Assigned: philikon)

References

Details

(Whiteboard: [strings])

Attachments

(5 files, 4 obsolete files)

Revamp the setup wizard according to Faaborg's mockups.
Blocks: 593427
No longer blocks: 593427
blocking2.0: --- → ?
Whiteboard: [strings]
Blocks: 593427
Blocks: 583653
Blocks: 587981
Generate Sync Key: Implement key generation and backup (email/print/save)
Assignee: nobody → philipp
Attachment #472537 - Flags: review?(dolske)
Generate Sync Key: Change the setup wizard to generate the Sync Key
Attachment #472538 - Flags: review?(dolske)
Generate Sync Key: Fix up the Change/Update Passphrase dialog in the preference pane.
Attachment #472539 - Flags: review?(dolske)
Change flow of setup wizard
Attachment #472540 - Flags: review?(dolske)
Restyle the setup wizard
Attachment #472541 - Flags: review?(dolske)
Attachment #472537 - Flags: review?(dolske) → review?(mconnor)
Attachment #472538 - Flags: review?(dolske) → review?(mconnor)
Attachment #472539 - Flags: review?(dolske) → review?(mconnor)
Attachment #472540 - Flags: review?(dolske) → review?(mconnor)
Attachment #472541 - Flags: review?(dolske) → review?(mconnor)
Small rev on v1: Make textboxes wider to accomodate long Sync Keys.
Attachment #472539 - Attachment is obsolete: true
Attachment #472625 - Flags: review?(mconnor)
Attachment #472539 - Flags: review?(mconnor)
Comment on attachment 472537 [details] [diff] [review]
Part 1 (v1): Implement key generation + backup

>diff --git a/browser/locales/en-US/chrome/browser/syncSetup.dtd b/browser/locales/en-US/chrome/browser/syncSetup.dtd
>@@ -46,6 +46,9 @@
> <!ENTITY setup.newAccountPrefs2.title.label "Browser Sync Preferences">
> <!ENTITY syncComputerName.label       "Computer Name:">
> <!ENTITY syncComputerName.accesskey   "c">
>+
>+<!ENTITY page.syncKeyBackup.title "Your Firefox Sync Key">
>+<!ENTITY page.syncKeyBackup.descr "This secret key is used to encrypt your personal data. It is not uploaded to the server and cannot be recovered. Do not lose it or share with other people.">

style nit: line up the strings, please.

>+email.synckey.subject = Your Firefox Sync Key
>+email.synckey.body = Congratulations for signing up for Firefox Sync! Your secret Firefox Sync key is %S. Do not lose it or share with other people.
>+save.synckey.title = Save Sync Key

same here
Attachment #472537 - Flags: review?(mconnor) → review+
Attachment #472538 - Flags: review?(mconnor) → review+
Attachment #472540 - Flags: review?(mconnor) → review+
Attachment #472541 - Flags: review?(mconnor) → review+
Attachment #472625 - Flags: review?(mconnor) → review+
Addressed review comments (style nits)
Attachment #472537 - Attachment is obsolete: true
Small rev on v1 after bug 578671 landed in fx-sync: "Sync this computer's" --> "Sync My"
Attachment #472540 - Attachment is obsolete: true
Small rev on v1: Fix JAR manifest for classic Windows theme.
Attachment #472541 - Attachment is obsolete: true
blocking2.0: ? → beta6+
Duplicate of this bug: 590138
Comment on attachment 472538 [details] [diff] [review]
Part 2 (v1): Generate the Sync Key in the setup wizard

>-          <textbox type="password" id="weavePassphrase"
>-                   onkeyup="gSyncSetup.checkFields()"
>-                   onchange="gSyncSetup.checkFields()"/>

(...)

>+      <textbox id="weavePassphrase"
>+               onkeyup="gSyncSetup.onPassphraseChange()"
>+               onchange="gSyncSetup.onPassphraseChange()"
>+               onfocus="this.select()"/>

Now it's not type="password" anymore. Was that change intentional? It looks really strange to see my key readable. :-/
(In reply to comment #13)
> Now it's not type="password" anymore. Was that change intentional? It looks
> really strange to see my key readable. :-/

Yes. We want users to save it by writing it down, copy'n'pasting or using one of the provided backup methods. See faaborg's mockups.
Depends on: 591118, 591120, 592839, 594056
No longer depends on: 589980
Regarding strings in syncGenericChange.properties

Is the mention of "secret phrase / passphrase"  in: 

change.synckey.error = There was an error while changing your secret phrase!
change.synckey.success = Your secret phrase was successfully changed!

intentional (as in, instead of "Sync key"), since all references to secret phrase has been changed to Sync key everywhere else by the landing yesterday ?
(In reply to comment #15)
> Is the mention of "secret phrase / passphrase"  in: 
> 
> change.synckey.error = There was an error while changing your secret phrase!
> change.synckey.success = Your secret phrase was successfully changed!
> 
> intentional (as in, instead of "Sync key")

I just caught this too. Not intentional, they must've slipped through the net. I already filed bug 594520.
Duplicate of this bug: 588164
Images sync-usedNever.png and sync-usedBefore.png can be removed or not?
They can be removed, yes.  File a followup please?
Blocks: 595603
(In reply to comment #19)
> They can be removed, yes.  File a followup please?

Filed bug 595603.
(In reply to comment #14)
> See faaborg's mockups.

Is there a link for these?

https://bugzilla.mozilla.org/attachment.cgi?id=468606

Is this it?
(In reply to comment #21)
> (In reply to comment #14)
> > See faaborg's mockups.
> 
> Is there a link for these?
> 
> https://bugzilla.mozilla.org/attachment.cgi?id=468606
> 
> Is this it?

Yes.
Blocks: 600940
Question from localizers: Should "Sync" in "Sync Key" be translated?
(In reply to comment #23)
> Question from localizers: Should "Sync" in "Sync Key" be translated?

That's a good question. I would say no. Sync is a brand name (see bug 596381 comment 11). That said, consistency is the most important aspect here: Firefox, Fennec and Firefox Home should all use the *same* wording in a particular language.
I assumed that both "sync" and "key" would be translated, unless Ragavan doesn't want us translating the brand name.
I know it's a bit too late to be commenting on an old bug...
I also can't find that google group thing for suggestions.

The new Sync UI looks nice, but it would look even better if it used the default set-up wizard on Aero, with it's guidelines.

The text on the current Sync UI wizard is a bit bloated, the titles are unreasonably big (especially the sync key page).

For example the initial setup page could easily be redesigned as such (quick mockup):
http://img714.imageshack.us/img714/186/aerowizard.png
(In reply to comment #26)
> I know it's a bit too late to be commenting on an old bug...

Indeed. Please always file a new bug or comment on ones that haven't been resolved yet. Bug 591122 seems appropriate for your suggestions.
You need to log in before you can comment on or make changes to this bug.