XML is displayed with no style.

RESOLVED FIXED

Status

()

RESOLVED FIXED
8 years ago
6 years ago

People

(Reporter: wanliyou, Assigned: sicking)

Tracking

(Depends on: 1 bug, {regression})

unspecified
x86
Windows XP
regression
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(blocking2.0 beta7+)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows NT 5.1; rv:2.0b5pre) Gecko/20100825 Minefield/4.0b5pre
Build Identifier: Mozilla/5.0 (Windows NT 5.1; rv:2.0b5pre) Gecko/20100825 Minefield/4.0b5pre

Open an XML file in previous builds, it's displayed with style, and we can even fold/unfold tags. But in nightly build, it's broken, only the text nodes are displayed.

Reproducible: Always
Regression range:

http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=9a623cc1c5e7&tochange=4a6ee9e82945

Jonas, I bet this is fallout from the remote XUL/XBL disabling.  Seems like this should block b5?
Blocks: 546857
Status: UNCONFIRMED → NEW
blocking2.0: --- → ?
Component: Layout: Text → XUL
Ever confirmed: true
Keywords: regression
QA Contact: layout.fonts-and-text → xptoolkit.widgets

Updated

8 years ago
Flags: in-testsuite?
blocking2.0: ? → beta5+
Assignee: nobody → jonas
Created attachment 470159 [details] [diff] [review]
Patch to fix (needs tests)

got r=mrbkap over irl
Attachment #470159 - Flags: review+
Should we check this in, pronto, or is there high enough chance of regression that we should push it off to b6?
Fixed friday night:

http://hg.mozilla.org/mozilla-central/rev/567c0e5bf04e

However I need to figure out a way to test this. We should probably set up a domain which doesn't support XUL.

Leaving as assigned to remind me to check in a test.
blocking2.0: beta5+ → beta6+
Actually, reftests run only as a single domain as I understand it. It might work to disable XUL, open an iframe with a raw xml document. Tell the reftest framework that the test is ready, and then in the unload handler re-enable XUL.
Duplicate of this bug: 591401

Updated

8 years ago
Attachment #470965 - Flags: review?(jst) → review+

Comment 8

8 years ago
FWIW this is now WFM on Mozilla/5.0 (Windows NT 6.0; rv:2.0b6pre) Gecko/20100901 Firefox/4.0b6pre ID:20100901041125
Checked in to m-c

http://hg.mozilla.org/mozilla-central/rev/83e9c68be99d
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Flags: in-testsuite? → in-testsuite+
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.