iCal server privacy flag not recognised (lacking support for X-CALENDARSERVER-ACCESS)

RESOLVED WONTFIX

Status

Calendar
Provider: CalDAV
RESOLVED WONTFIX
7 years ago
6 years ago

People

(Reporter: Stefan Winter, Unassigned)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.2.8) Gecko/20100723 SUSE/3.6.8-1.3 Firefox/3.6.8
Build Identifier: Lightning 1.0b2 plugin in Thunderbird 3.1

Hi,

Apple's iCal Server supports private events by marking events with
X-CALENDARSERVER-ACCESS:CONFIDENTIAL

This is documented at http://svn.calendarserver.org/repository/calendarserver/CalendarServer/trunk/doc/Extensions/caldav-privateevents.txt

Lightning also supports a keyword "confidential", but doesn't map this to the above keyword in ICS, i.e. when creating an iCal event with iCal Client on Mac OS, other iCal Client clients see only date and time, while other Lightning clients with CalDAV see the full event.

I have attached a sample iCal event as exported from iCal server to demonstrate how such events look like.

Would be nice to recognise the flag; even if this is only a X- extension for iCal server.

Greetings,

Stefan Winter

Reproducible: Always

Steps to Reproduce:
1. create private event with iCal client
2. subscribe to calendar with Lightning
3. all details of event are visible in Lightning


Expected Results:  
X-CALENDARSERVER-ACCESS:CONFIDENTIAL should be treated the same as the status "confidential" for internal calendars
(Reporter)

Comment 1

7 years ago
Created attachment 469354 [details]
a confidential event

Updated

7 years ago
Attachment #469354 - Attachment mime type: text/calendar → text/plain

Comment 2

7 years ago
Access classification can be defined using the CLASS property as defined in the iCalendar specification (RFC 5545), e.g. CLASS:PRIVATE or CLASS:CONFIDENTIAL. I assume this is the one used by Lightning.
(Reporter)

Comment 3

7 years ago
Ah, I see. CLASS is defined to be within the VEVENT; while the sample iCal Server event carries X-CALENDARSERVER-ACCESS within the VCALENDAR object.

The semantics seems to be different as well. CLASS signifies the properties of an event, while X-CALENDARSERVER-ACCESS is sortof a supplement to WebDAV ACLs (but they express mostly the same visibility constraints for the contained objects).

I guess arguably iCal Server should mirror its X-CALENDARSERVER-ACCESS value also as CLASS within the VEVENT?

I can always ask on iCal server MLs/forums. But would it be much work to scan a CalDAV resource for X-CALENDARSERVER-ACCESS and act accordingly anyway?

Greetings,

Stefan Winter
I think the iCal server should try to conform to the spec instead of Lightning trying to conform to a iCal server specific syntax. Marking WONTFIX.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.