bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Some images fail to redraw upon fast scrolling with Direct2D on

RESOLVED DUPLICATE of bug 587508

Status

()

Core
Graphics
RESOLVED DUPLICATE of bug 587508
8 years ago
8 years ago

People

(Reporter: Nouiwi, Unassigned)

Tracking

Trunk
x86
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; rv:2.0b4) Gecko/20100818 Firefox/4.0b4 ( .NET CLR 3.5.30729; .NET4.0E)
Build Identifier: Mozilla/5.0 (Windows NT 6.1; rv:2.0b4) Gecko/20100818 Firefox/4.0b4 ( .NET CLR 3.5.30729; .NET4.0E)

With Direct2D on, scrolling past some images (the ones in the STP are below a marquee [animated text, scrolling horizontally] text) then back up towards them causes them to disappear with random parts of the screen drawn in their stead. Hovering the mouse on them redraws them and the display is correctly refreshed within a second.

Reproducible: Always

Steps to Reproduce:
1.Go to http://www.elkhabar.com/accueil/ [Algerian newspaper website, Arabic]
2.Scroll down until you are past the marquee text (towards the middle of the page, set off with red line above and below, 4 images below it, and still below, a series of links), that is, the marquee and the images are no longer visible on the screen
3.Move back up quickly (I drag the Scroll bar, but happens sometimes also when I use my intellimouse) till you reach the marquee and the images
Actual Results:  
The images under the marquee are no longer visible and some random part of the screen is reproduced in their stead.

Expected Results:  
The images should display in one row, as seen in the first pass.

Using Nvidia GeForce 8400 GS, Driver version: 8.17.11.9745 (WDDM1.1) on a 2GB-RAM, E5200 Pentium Dual-Core (2.5GHz) desktop. Theme is "Dreamy Ginkgo Leaves", a persona by Lucky9.
(Reporter)

Comment 1

8 years ago
Stumbled upon another case, involving a flash animation this time.
STP:
1. Go to http://www.autoalgerie.com/ [French]
2. There are several flash ads, scroll quickly past them and back, and watch the delay in their redrawing.
It is less severe here, and the refresh to expected display seems faster and occurs without any action on the user (e.g. mouse hovering like above).
Component: General → Graphics
Product: Firefox → Core
QA Contact: general → thebes
Version: unspecified → Trunk
Aha! Those images are actually a flash applet. We have some issues with redrawing Flash right now with D2D, but we're working on it! Thanks for the report.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 587508
You need to log in before you can comment on or make changes to this bug.