Closed Bug 590874 Opened 9 years ago Closed 9 years ago

intermittent timeout in /tests/parser/htmlparser/tests/mochitest/test_bug534293.html

Categories

(Core :: DOM: HTML Parser, defect)

defect
Not set

Tracking

()

RESOLVED FIXED

People

(Reporter: mak, Assigned: hsivonen)

References

(Depends on 1 open bug)

Details

(Keywords: intermittent-failure)

Attachments

(1 file)

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1282812304.1282813112.9137.gz

25 INFO TEST-START | /tests/parser/htmlparser/tests/mochitest/test_bug534293.html
26 ERROR TEST-UNEXPECTED-FAIL | /tests/parser/htmlparser/tests/mochitest/test_bug534293.html | Test timed out.
27 INFO SimpleTest finished /tests/parser/htmlparser/tests/mochitest/test_bug534293.html in 328194ms
The only explanation I have for the timeout is that the timer in http://mxr.mozilla.org/mozilla-central/source/parser/htmlparser/tests/mochitest/file_bug534293-slow.sjs doesn't work as intended. 

jwalden, do you see something wrong with that use of nsITimer?
I just saw bug 590713.
Depends on: 590713
OS: Mac OS X → All
Hardware: x86 → All
It looks like that the failure is very close to 100% on Mac OSX 32 bits. At least, since 12 hours, it passes only once. Maybe a good hint to investigate?
This is beginning to feel like a nearly perma-orange.  Henri, could you please either investigate this, or disable the test until the issue is resolved?
Attached patch Disable the testSplinter Review
Patch to disable the test given bug 590713 comment 2.
Assignee: nobody → hsivonen
Status: NEW → ASSIGNED
Attachment #475021 - Flags: review?(bzbarsky)
Comment on attachment 475021 [details] [diff] [review]
Disable the test

r=me
Attachment #475021 - Flags: review?(bzbarsky) → review+
http://hg.mozilla.org/mozilla-central/rev/3bc59ea9b0af
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Whiteboard: [orange]
You need to log in before you can comment on or make changes to this bug.