Artifacts in message view when scrolling slowly down with mouse wheel

RESOLVED INVALID

Status

Thunderbird
Message Reader UI
--
major
RESOLVED INVALID
8 years ago
8 years ago

People

(Reporter: Martin Häcker, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [add-on: CompactHeade / Lightning / Display Mail User Agent])

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_6_4; de-de) AppleWebKit/534.6+ (KHTML, like Gecko) Version/5.0.1 Safari/533.17.8
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; de; rv:1.9.2.8) Gecko/20100802 Lightning/1.0b2 Thunderbird/3.1.2

Hi there,

if I scroll slowly down with the scroll wheel in the message view I always get black artifacts in the view that make reading the messages uneccessary hard (besides looking ugly).

They are not present when scrolling through the mail by hitting the spacebar or by clicking on the scrollbar (but I sugges that is just because each scroll operation only generates a tiny smear and it is this scroll operation will generate just one at the top of the window where it doesn't hurt.

Reproducible: Always

Steps to Reproduce:
1. View mail with more text than fits on the screen
2. scroll slowly with the mousewheel down
3. view artifacts
Actual Results:  
artifacts appear

Expected Results:  
no artifacts should appear

I've attached a screenshot of how it looks like
(Reporter)

Comment 1

8 years ago
Created attachment 469450 [details]
screenshot of the problem
I'm seeing this sporadicly , but don't have prceise STRs :-(. I think Mark raised a similar bug, mark do you have the bug number handy ?
Component: General → Mail Window Front End
QA Contact: general → front-end
Whiteboard: dupme

Comment 3

8 years ago
The artifacts are even worse, when scrolling on the MacBook Pro's Multi-Touch Trackpad.

Comment 4

8 years ago
I also get a single horizontal white line when I use space bar for scrolling (at the point where the message end in the displayable pane). It is unreadable when using a macbook pro trackpad.

This issue was not present in the in older 2.x product.

Comment 5

8 years ago
Just upgraded to Thunderbird 3.1.4 - the problem has not been solved.

Comment 6

8 years ago
I'm seeing this too.

See also: https://bugzilla.mozilla.org/show_bug.cgi?id=595676

Comment 7

8 years ago
I can confirm that disabling or uninstalling the Lightning 1.0b2 extension fixes this issue. Use Apple iCal instead - problem solved.

Comment 8

8 years ago
I guess it depends on what your view of "the problem" is.
For me, "the problem" is that Lightning doesn't work correctly.
Using iCal doesn't make Lightning work correctly.  I use Lightning
on several different machines and appreciate the consistent interface;
not all of my machines come from Apple.

Updated

8 years ago
Component: Mail Window Front End → Message Reader UI
QA Contact: front-end → message-reader

Comment 9

8 years ago
I have found that if I disable the CompactHeader addon I don't get the problem any more. Can't say I'm happy with the fix but it at least makes TB usable again. The author of the add-on seems to blame graphics drivers - I'm using OSX 10.5.8 and have all updates applied (but I'm not sure if the referenced graphics update applies to Leopard - it looks like a snow leopard fix)

Comment 10

8 years ago
At first I thought that disabling CompactHeaders solved the problem, but it
turned out not to be the case.

Are you using Lightning?  If not, it may be that CompactHeaders is another
extension that triggers an "off by one" bug in the Thunderbird message pane
scrolling code.  (Or maybe it's in the graphics driver, but TB2 never had
this problem with the same graphics drivers.)

Comment 11

8 years ago
I don't think I'm using Lightning (it doesn't show in my Add-Ons) - so I guess it is CompactHeaders that triggers it. Like you said - TB2 didn't have this issue, its when I upgraded to TB3. Now that I know there is a workaround (albeit a bit annoying) - I may try upgrading on my other computer which is Snow Leopard but with the same setup, and see if I get the same problem - that would confirm if its a graphics driver issue I guess.

I'm kind of suprised this issues hasn't had more airplay - but maybe mac users don't use TB much (I'm using it for following newsgroups - where its very good - or at least was)

Comment 12

8 years ago
(In reply to comment #2)
> I'm seeing this sporadicly , but don't have prceise STRs :-(. I think Mark
> raised a similar bug, mark do you have the bug number handy ?

I don't find any related bugs that mark authored or cc: to in last 200 days

Comment 13

8 years ago
I found a solution. 
If I disable Display Mail User Agent 1.6.6 add-on problem disappeared.
Duplicate of this bug: 610989
(In reply to comment #13)
> I found a solution. 
> If I disable Display Mail User Agent 1.6.6 add-on problem disappeared.

Are the other people seeing this bug using this extension too ?
Whiteboard: dupme

Comment 16

8 years ago
(In reply to comment #15)
> Are the other people seeing this bug using this extension too ?

I know only about Yuxuan Wang - https://bugzilla.mozilla.org/show_bug.cgi?id=602938#c7

Comment 17

8 years ago
Some update I installed in the last few months made this problem go away.
Or at least I haven't seen it for months.

Comment 18

8 years ago
As indicated in comment 13.
Disabling Display Mail User Agent 1.6.6, made the artifacts a problem of the past.
(Thunderbird 3.1.7 ID:20101207114001) Mac OSX 10.6.6 (intel)

thnx.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INVALID

Comment 19

8 years ago
Well, I don't have that plugin installed, but instead for me it is triggered by the plugin "CompactHeader".

So this is not a problem of an individual plugin but instead of the API of how they interact with the email view.

That should be fixed!

How do I reopen this issue?

Comment 20

8 years ago
Is this only on Mac?
Whiteboard: [add-on: CompactHeade / Lightning / Display Mail User Agent]

Comment 21

8 years ago
Yes, this is a Mac only issue.

Further observations:
If the window is not maximized, the scrolling works, if the window is not resized to be a tall as the screen. In this case it works even though "Display Mail User Agent 1.6.6" and "Lightning 1.0b2" extensions are installed and enabled.

Maximize the window, or resize to maximum height and the bug is back!

This seem to be an "off-by-one" bug in Thunderbirds scroll handler.
You need to log in before you can comment on or make changes to this bug.