High CPU usage when global indexing is turned on

RESOLVED INVALID

Status

MailNews Core
Backend
--
major
RESOLVED INVALID
7 years ago
7 years ago

People

(Reporter: preko1984, Unassigned)

Tracking

({perf})

1.9.2 Branch
x86_64
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [indexing is operating properly][support][dupme])

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; hu; rv:1.9.2.8) Gecko/20100722 Firefox/3.6.8
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; hu; rv:1.9.2.8) Gecko/20100802 Thunderbird/3.1.2

I have been using Thunderbird for years and with the coming of the v3 versions it has indexed all my emails which is more than 10GB. It was working with v3.x for months.
Today I installed 3.1.2 and since then Thunderbird is using 40-70% of CPU all the time. The problem is gone when I turn down global indexing.

Reproducible: Always

Steps to Reproduce:
1. Turn on global indexing.
2. Restart
Actual Results:  
CPU usage is 40-70% all the time.

Expected Results:  
Low CPU usage or at least some information on the status of the indexing.
Component: General → Backend
Keywords: perf
Product: Thunderbird → MailNews Core
QA Contact: general → backend
Status of indexing is available in Tools -> activity manager.

Comment 2

7 years ago
I think what preko means is he wants to see the current level of progress of indexing. There is no such indicator in Thunderbird. But http://getsatisfaction.com/mozilla_messaging/topics/how_to_exclude_certain_folders_from_indexing describes the addon which allows you to see which message are and are not indexed.

Thunderbird will be in a steady high cpu state until all your messages are indexed, which for 10GB will be a long time. And your disk space and search index will be DOUBLE your gmail message store if the "All Mail" folder is subscribed. You probably want to unsub that folder.  References:
http://support.mozillamessaging.com/ko/kb/Thunderbird+and+Gmail
http://kb.mozillazine.org/Using_Gmail_with_Thunderbird_and_Mozilla_Suite#Subscriptions
http://forums.mozillazine.org/viewtopic.php?f=28&t=1687205&start=30

Your description indicates normal behaviour, and that this is not causing you problems, so I will close this bug as invalid.  But if you see that this activity causes problems on your system please comment in the bug.  And thanks for taking the time to help make Thunderbird better.

This bug may be a duplicate if someone wants to try to find it = dupme
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INVALID
Whiteboard: [indexing is operating properly][support][dupme]
Version: unspecified → 1.9.2 Branch
(Reporter)

Comment 3

7 years ago
It managed to index all my mail when left for the whole night. I did not know about the Activity Manager, thanks!
So now this issue is solved for me, indexing works as intended, but it would be nice to improve the communication with the user.

Thunderbird should estimate the time needed for indexing and ask for a permission to do that now. For example, it should not start indexing when the laptop works from battery (it was the case for me). Maybe a simple popup would be enough with two options:
1. Start indexing now - high CPU usage for 3h 24m (estimated)
2. Turn off indexing - you can turn it on again and start indexing from Settings/General
> Thunderbird should estimate the time needed for indexing and ask for a
> permission to do that now. For example, it should not start indexing when the
> laptop works from battery (it was the case for me). Maybe a simple popup would
> be enough with two options:
> 1. Start indexing now - high CPU usage for 3h 24m (estimated)
> 2. Turn off indexing - you can turn it on again and start indexing from
> Settings/General

see bug 475505
You need to log in before you can comment on or make changes to this bug.