Hardcoded chrome URL to a GIF file in netwerk/streamconv/converters/mozTXTToHTMLConv.cpp

RESOLVED DUPLICATE of bug 84950

Status

P3
normal
RESOLVED DUPLICATE of bug 84950
18 years ago
11 years ago

People

(Reporter: bzbarsky, Unassigned)

Tracking

({helpwanted})

Trunk
Future
helpwanted

Firefox Tracking Flags

(Not tracked)

Details

Lots of lines of the form:

SmilyHit(aInString, aInLength, col0, ":-)", 3, "<img
src=\"chrome://messenger/skin/smile.gif\" alt=\":-)\" class=\"moz-txt-smily\"
height=17 width=17 align=ABSCENTER>", outputHTML, glyphTextLen)

These should not be hardcoded.
(Reporter)

Updated

18 years ago
Summary: Hardcoded chrome URL to a GIF file in extensions/xmlterm/base/mozXMLTermSession.cpp → Hardcoded chrome URL to a GIF file in netwerk/streamconv/converters/mozTXTToHTMLConv.cpp
(Reporter)

Updated

18 years ago
Blocks: 59091

Comment 1

18 years ago
Pretriage of skinnability bugs, marking nsbeta1-. The real question is how to 
allow people to load up an icon using common dialog services without referencing 
a filename. Certainly not going to get fixed for beta1.
Keywords: nsbeta1-

Comment 2

18 years ago
Marking nsbeta1- bugs as future to get off the radar
Target Milestone: --- → Future

Updated

18 years ago
QA Contact: blakeross → pmac
Mass move skinability bugs to nobody@mozilla.org, helpwanted. 
Assignee: ben → nobody
Keywords: helpwanted
the chrome urls in that file have moved inside the SmilyHit function, as:
722     outputHTML += NS_LITERAL_STRING("<img
src=\"chrome://editor/content/images/");

*** This bug has been marked as a duplicate of 84950 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
(Assignee)

Updated

11 years ago
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.