Add-ons and extensions cause firefox to hang.

RESOLVED DUPLICATE of bug 590608

Status

()

--
major
RESOLVED DUPLICATE of bug 590608
8 years ago
8 years ago

People

(Reporter: sburman, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2.8) Gecko/20100722 Firefox/3.6.8 (.NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; .NET4.0C)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2.8) Gecko/20100722 Firefox/3.6.8 (.NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; .NET4.0C)

When opening firefox, a message appears, denoting an error in the java for the extensions menu.

Many of my add-on extensions fail to function including the Google toolbar, Zotero, and forecastfox.

When going through the tools menu to the add-ons menu, Firefox hangs.

If all add-ons are disabled, Firefox works flawlessly. However, when reactivating the add-ons, one by one, there is no problem. Once reactivated, firefox continues to function normally throughout the session. Some time later, the problem redevelops.


Reproducible: Sometimes

Steps to Reproduce:
It happens pretty frequently, but not every time I use firefox. Especially if I have recently disabled and re-enabled all of my add-ons, it will take some time for it to repeat.

1.
2.
3.

Comment 1

8 years ago
Did you just update to Personas Plus 1.6? If so, this is bug 590608.
(Reporter)

Comment 2

8 years ago
I did - and I have been having that problem as well, however since it causes no particular issue with firefox, I've just ignored it. This is different, next time it occurs, I'll post the message in the box. This has warning messages regarding the java of forecastfox and the extension menu itself. I just reinstalled firefox - I'm hoping it happens again so that I can post.

Comment 3

8 years ago
If you have Personas Plus 1.6 installed please load up Firefox safe mode and uninstall it. It with Google Toolbar (or possibly without) is causing many other problems in other extensions. Forecastfox has been mentioned as one of the casualties from this update.
http://support.mozilla.com/en-US/kb/Safe+Mode

After that, you can restart Firefox and things should work. You can install the
old version of Personas Plus 1.5.3 if you want which does not seem to break.
https://addons.mozilla.org/addon/10900/versions/#version-1.5.3
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 590608

Comment 4

8 years ago
In response to the email you sent me, yes what you're describing in this error:

'[JavaScript Error: "dir is null" {file: 
"file:///C:/Users/Scott/AppData/Roaming/Mozilla/Firefox/Profiles/dcya5l3u.default/extensions/%7B0538E3E3-7E9B-4d49-8831-A227C80A7AD3%7D/components/nsForecastfox.js" 
line: 323}]' when calling method: [ffIDiskService::get]

Does appear to be from bug 590608. This sort of Forecastfox error has been reported elsewhere. Please read comment 3 here and uninstall Personas Plus 1.6 to fix your problems here. If you need to stop the stalling Firefox, use the Windows task manager: http://support.microsoft.com/kb/323527

In the future, please only reply in the bug rather than via email here.
You need to log in before you can comment on or make changes to this bug.