Closed Bug 591008 Opened 12 years ago Closed 12 years ago

browser_HUDServiceTestsAll.js | image is logged - Didn't expect -1, but got it

Categories

(DevTools :: General, defect)

defect
Not set
critical

Tracking

(Not tracked)

RESOLVED FIXED
Firefox 4.0b5

People

(Reporter: ddahl, Assigned: julian.viereck)

References

()

Details

(Keywords: intermittent-failure)

Attachments

(2 files)

Seems like we have another random orange, this came up right after we pushed the image logging. It only manifested on windows.
Blocks: 438871
OS: Windows Vista → Windows Server 2003
Whiteboard: [orange]
Summary: browser_HUDServiceTestsAll.js | log() is logged - Didn't expect -1, but got it → browser_HUDServiceTestsAll.js | image is logged - Didn't expect -1, but got it
Pretty sure I have a fix for this.
Attached patch orange-fix 0Splinter Review
Attachment #469639 - Flags: review?(sdwilsh)
Not Windows only, and this is far and away our most frequent orange.
Severity: normal → critical
OS: Windows Server 2003 → All
Hardware: x86 → All
Comment on attachment 469639 [details] [diff] [review]
orange-fix 0

>+    executeSoon(function (){
nit: space after ()

r=sdwilsh
Attachment #469639 - Flags: review?(sdwilsh)
Attachment #469639 - Flags: review+
Attachment #469639 - Flags: approval2.0+
http://hg.mozilla.org/mozilla-central/rev/c877b9e86e4d
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
(comment 49 was 2 cycles before the push in comment 48)
Bad news -- comment 51 was from the cycle that had this bug's fix.

Looks like it's not fixed after all. :-/
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
yeah - this is only manifesting itself on the build machines. We have started a quick re-factor of our test code. should be landing soon: bug 581069
Attached patch orange-fix 1Splinter Review
This is a second attempt to fix the problem with random orange.

The number of logged nodes to the webconsole is all the time correct. Just the tests for image and log() fail. Currently, the unit tests checks if the image comes as 3rd log output and the log() as 4th log output. This is how it should be when looking at the html file. However, it might be the case where the log() is logged first before the image is logged. This patch checks the image to be at position 3 and 4 as well as the log() output to be at position 3 and 4.

I can't reproduce this random orange problem in my local build. Therefore this patch is pure theory but I think it sounds reasonable and might be worth trying.
Attachment #470192 - Flags: feedback?(ddahl)
Attachment #470192 - Flags: feedback?(ddahl) → feedback+
Attachment #470192 - Flags: review?(sdwilsh)
Comment on attachment 470192 [details] [diff] [review]
orange-fix 1

ddahl is an acceptable reviewer for this test
Attachment #470192 - Flags: review?(sdwilsh) → review?(ddahl)
Attachment #470192 - Flags: review?(ddahl) → review+
Keywords: checkin-needed
http://hg.mozilla.org/mozilla-central/rev/3ec56ec77529
Assignee: nobody → jviereck
Status: REOPENED → RESOLVED
Closed: 12 years ago12 years ago
Flags: in-testsuite+
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 4.0b5
Whiteboard: [orange]
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.