500 Internal Error when trying to search for a testcase

RESOLVED FIXED

Status

Testopia
Search
--
major
RESOLVED FIXED
8 years ago
7 years ago

People

(Reporter: jonozzz, Assigned: Greg Hendricks)

Tracking

Details

Attachments

(1 attachment)

1.95 KB, patch
Max Kanat-Alexander
: review?
Greg Hendricks
Details | Diff | Splinter Review
(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.8) Gecko/20100722 Firefox/3.6.8 (.NET CLR 3.5.30729)
Build Identifier: 

http://xxx/tr_query.cgi?current_tab=case returns a: 500 Error.

Apache log shows only:
[Thu Aug 26 07:58:05 2010] [error] [client 192.168.42.72] Premature end of script headers: tr_query.cgi, referer: http://xxx/tr_show_product.cgi?search=1

Same story goes for:
http://xxx/tr_query.cgi?current_tab=run
http://xxx/tr_query.cgi?current_tab=case_run


Reproducible: Always

Steps to Reproduce:
1. Login as an user;
2. Click on Testopia's "Search" link;

Actual Results:  
An empty page shows up in Firefox.

Expected Results:  
Test case search page expected.

Comment 1

8 years ago
this was introduced by revision 640
ghendricks@novell.com-20100721172002-ncb13aem53zw5nbk

moving $class->SUPER::new(@_); in TestRun.pm's constructor to before the empty object creation stuff breaks things.  As there was a fair bit of this type of change in that revision, I suspect there are probably more conceptually-related problems in the other classes, but it certainly shows up for the Test Run Report.

Comment 2

8 years ago
Actually the problem I pointed out was only for the run and case_run tabs, for the case tab, just changing how the object constructor is called in tr_query.cgi might be the most apropriate solution...that's what I'm going with anyway.  I'll attach a couple of patches.

Comment 3

8 years ago
Created attachment 485198 [details] [diff] [review]
fixes reports
(Reporter)

Comment 4

8 years ago
That works. Actually I ended up monkeypatching the run and case_run tabs, but I think your patch is more educated :) Any chances to merge it into the trunk ?

Comment 5

8 years ago
Anyone knows when the fix for this bug will be incorporated to a version of Bugzilla and/or Testopia?

Comment 6

8 years ago
I'm seeing this problem as well.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

8 years ago
Attachment #485198 - Flags: review?(gregaryh)

Updated

8 years ago
Duplicate of this bug: 625076

Comment 8

8 years ago
I have been seeing similar problem with search and report.  I can run the Plan search or report, but not others.
After found this bug report and fix, I applied this fix and both Run and Case-Run or Results search and report worked, but not case as mentioned Jamie's comments.  Thank you Jamie for this.
I would love to see the case report and search working soon.
(Assignee)

Comment 9

8 years ago
r648
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED

Comment 10

7 years ago
This changes in the attachment worked for me!
You need to log in before you can comment on or make changes to this bug.