wiki.mozilla.org error: CdbReader_PHP::read: read from cdb file failed, file may be corrupted

RESOLVED DUPLICATE of bug 589780

Status

mozilla.org Graveyard
Server Operations
RESOLVED DUPLICATE of bug 589780
7 years ago
3 years ago

People

(Reporter: humph, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

7 years ago
I'm trying to hit this page:

https://wiki.mozilla.org/Audio_Data_API

and getting this:

MozillaWiki error

CdbReader_PHP::read: read from cdb file failed, file may be corrupted

Backtrace:

#0 /data/www/wiki.mozilla.org/includes/Cdb_PHP.php(193): CdbReader_PHP->read(8, 40698)
#1 /data/www/wiki.mozilla.org/includes/Cdb_PHP.php(208): CdbReader_PHP->findNext('messages:missin...')
#2 /data/www/wiki.mozilla.org/includes/Cdb_PHP.php(112): CdbReader_PHP->find('messages:missin...')
#3 /data/www/wiki.mozilla.org/includes/LocalisationCache.php(864): CdbReader_PHP->get('messages:missin...')
#4 /data/www/wiki.mozilla.org/includes/LocalisationCache.php(307): LCStore_CDB->get('en', 'messages:missin...')
#5 /data/www/wiki.mozilla.org/includes/LocalisationCache.php(225): LocalisationCache->loadSubitem('en', 'messages', 'missing-article')
#6 /data/www/wiki.mozilla.org/languages/Language.php(1464): LocalisationCache->getSubitem('en', 'messages', 'missing-article')
#7 /data/www/wiki.mozilla.org/includes/MessageCache.php(532): Language->getMessage('missing-article')
#8 /data/www/wiki.mozilla.org/includes/GlobalFunctions.php(742): MessageCache->get('missing-article', true, false)
#9 /data/www/wiki.mozilla.org/includes/GlobalFunctions.php(707): wfMsgGetKey('missing-article', true, false, false)
#10 /data/www/wiki.mozilla.org/includes/GlobalFunctions.php(622): wfMsgReal('missing-article', Array, true, false, false)
#11 /data/www/wiki.mozilla.org/includes/Article.php(448): wfMsgNoTrans('missing-article', 'Audio Data API', '')
#12 /data/www/wiki.mozilla.org/includes/Article.php(343): Article->fetchContent(0)
#13 /data/www/wiki.mozilla.org/includes/Article.php(230): Article->loadContent()
#14 /data/www/wiki.mozilla.org/includes/Article.php(832): Article->getContent()
#15 /data/www/wiki.mozilla.org/includes/Wiki.php(493): Article->view()
#16 /data/www/wiki.mozilla.org/includes/Wiki.php(70): MediaWiki->performAction(Object(OutputPage), Object(Article), Object(Title), Object(User), Object(WebRequest))
#17 /data/www/wiki.mozilla.org/index.php(117): MediaWiki->performRequestForTitle(Object(Title), Object(Article), Object(OutputPage), Object(User), Object(WebRequest))
#18 {main}
(Reporter)

Comment 1

7 years ago
Not sure what changed, but now it's working for me.  I'll re-open if it becomes necessary.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED

Updated

7 years ago
Resolution: FIXED → DUPLICATE
Duplicate of bug: 589780
Product: mozilla.org → mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.