No Window until deleted ~/Application Support/Firefox

RESOLVED WORKSFORME

Status

()

Firefox
General
--
critical
RESOLVED WORKSFORME
8 years ago
6 years ago

People

(Reporter: Nolan, Unassigned)

Tracking

4.0 Branch
x86_64
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [testday-20120413])

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b4) Gecko/20100818 Firefox/4.0b4
Build Identifier: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b4) Gecko/20100818 Firefox/4.0b4

I was using firefox 4 beta 4 and it would not produce a window. I would click the icon, window would never appear, icon would stop bouncing as in it was in the running state, but the window never appeared. 

This happened after an application restart, OS restart, and application reinstall. The situation was finally fixed when I deleted both my firefox folder in application support as well as the .app. Now it is working just fine. 

This is a standard install in the /Applications folder, appliication was running under a standard user account. When I sampled the process (when it was having issues) there were no major hangs. I could request new windows, tabs, hide/unhide, the window never showed. 

Reproducible: Didn't try

Steps to Reproduce:
1.Install firefox. 
2.???????????????
3.BUG!
(Reporter)

Comment 1

8 years ago
Want to be verbose in saying, deleting the .app and application support/firefox folders and reinstalling fixed the problem. This is not an issue that needs a reply.

Comment 2

8 years ago
This seems to be a newly frequent issue:

see also bugs 593032, 589969, 591532, 591176

Before I dupe, I'd like some more info:

Reporter, can you answer the following:

What version of Firefox did you FIRST see this happening in (Firefox 4 betas, 3.6, 3.5?)
Did you recently apply an OSX software update? Can you also tell me your OS version (Go to the Apple menu > About this Mac, click More Info and select Software from the left menu.) What is the full System Version? It should start Mac OS X 10.6.4 but I need the bit after that.
Do you regularly connect your mac up to a second monitor? When this happened, was this monitor connected?

Thanks!
(Reporter)

Comment 3

8 years ago
Ah, so it's not just me, I couldn't find it searching. Here's a little update. 

I reinstalled firefox and it was working as I said above, it starting acting this way again. It reproduced itself. And eventually it started working again... I didn't do anything to it, it just started not working then working again. 

As for your questions... The version I first saw this in is the most current firefox. Firefox 4 beta 4. 

I am pretty sure I have not patched since installing firefox 4 beta 4. OS X version is   System Version:    Mac OS X 10.6.4 (10F569). 

I have never connected my mac to a second monitor.

Updated

7 years ago
Version: unspecified → 4.0 Branch
This bug was reported using a pre-release version of Firefox 4. Now that Firefox 4.0.1 final has been released, can you please update and retest your bug? A fresh profile would be a good starting place to test, 
http://support.mozilla.com/kb/Managing+profiles. If you continue to see the issue, can you please update this bug with your results?

Filter: firefox4prebugsunco
cant reproduce on Firefox 11, 12b4,13 and 14

for support, please ask question in https://support.mozilla.org/questions/new
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
Whiteboard: [testday-20120413]
You need to log in before you can comment on or make changes to this bug.