Closed Bug 591197 Opened 9 years ago Closed 9 years ago

Closing the lastest tab group in Panorama shutdown firefox and cause the app tabs to be lost

Categories

(Firefox Graveyard :: Panorama, defect)

x86
Windows XP
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 576427

People

(Reporter: digitaljail, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows NT 5.1; rv:2.0b4) Gecko/20100818 Firefox/4.0b4
Build Identifier: Mozilla/5.0 (Windows NT 5.1; rv:2.0b4) Gecko/20100818 Firefox/4.0b4

Closing the lastest tab group in Panorama shut down firefox without prompt for save the session.

After restart all the app tabs are lost and Panorama start up with the Introduction video again.

Reproducible: Always

Steps to Reproduce:
1. Make sure you do not have set the Option "General" > "Startup" > "When FireFox Start" > "Show my windows and tabs from last time"
2. Open FireFox 4 beta 4 with a couple of App Tabs (if you do not have app tabs create some of those and start over)
3. Switch to Panorama by clicking the Panorama Icon
4. Close all the tab groups with the upper right "x" (when you close the last one FireFox should shutdown with no prompt to save your session).
5. Restart FireFox 4 beta 4 with the same profile.
Actual Results:  
All the App Tabs are lost and Panorama starts up with the Introduction video.

Expected Results:  
Have all the app tabs saved as usual (and maybe not have the Panaorama Intro Video there)

- No extensions installed for beta 4 profile.
- Beta 4 dedicated profile for a clean and neat test.
- Imported bookmarks from 3.6.x with the "restore function".
- Started up a new account for "Sync".
Status: UNCONFIRMED → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 576427
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.