[d2d+Aero]Repaint issue of flash player (wmode is not specified, i.e wmode=window)

RESOLVED DUPLICATE of bug 587508

Status

()

defect
RESOLVED DUPLICATE of bug 587508
9 years ago
9 years ago

People

(Reporter: alice0775, Unassigned)

Tracking

({regression})

Trunk
x86
Windows 7
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

()

Attachments

(1 attachment)

Posted image screenshot
User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b5pre) Gecko/20100826 Minefield/4.0b5pre ID:20100826120500
Build Identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b5pre) Gecko/20100826 Minefield/4.0b5pre ID:20100826120500

It only happens under condition of Enabled D2D and Windows7 Aero Style and wmode=window.
(IOW, it does not happens with disabled D2d or Windows7 Classic style) or wmode !=window)

Scroll up and down causes repaint issue of flash player.

Maybe related Bug 589305 and Bug 587442. but they do not mention d2d and window style.

Reproducible: Always

Steps to Reproduce:
1. Start Minefield with new profile + D2D + Windows7 Aero style
2. Open URL ( http://www.youtube.com/watch?v=0nMweBwTO8o&feature=related )
3. Scroll up and down

Actual Results:
 Repaint issue of flash player

Expected Results:
 Repaint properly.


Regression window:
Works:
http://hg.mozilla.org/mozilla-central/rev/92339b84d089
Mozilla/5.0 (Windows; Windows NT 6.1; WOW64; en-US; rv:2.0b2pre) Gecko/20100715 Minefield/4.0b2pre ID:20100715145415
Fails:
http://hg.mozilla.org/mozilla-central/rev/e1d7fd5255fd
Mozilla/5.0 (Windows; Windows NT 6.1; WOW64; en-US; rv:2.0b2pre) Gecko/20100715 Minefield/4.0b2pre ID:20100715152722
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=92339b84d089&tochange=e1d7fd5255fd
Candidate:
Bug 564991 - Retain layers and layer contents
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 587508
You need to log in before you can comment on or make changes to this bug.