Google Docs displaying mobile version of document creator for versions > 4.0b3 and on Minefield

RESOLVED WORKSFORME

Status

Tech Evangelism Graveyard
English US
RESOLVED WORKSFORME
8 years ago
3 years ago

People

(Reporter: Tobbi, Unassigned)

Tracking

Details

(Reporter)

Description

8 years ago
When you go to https://docs.google.com/#all and click the Create new > document button, all you get is the mobile google docs version.

I think this has something to do with Google's UA tracking. They apparently haven't added 4.0b something to their list of UAs yet and assume this is a mobile browser that's accessing the Google docs.

Works fine with other types of docs (presentation, spreadsheet etc.)

Comment 1

8 years ago
Maybe another case of sniffing for "pre"? Does this happen in Minefield as well? (Hotmail, as well as other Microsoft Live properties, has been a high-profile problem in this regard of late.)

Comment 2

8 years ago
Did some user agent testing and it might be caused by the removal of some items in the user agent.

Adding an extra Windows; to the user agent (e.g. via general.useragent.override) seems to work.

Mozilla/5.0 (Windows; Windows NT 6.0; rv:2.0b4) Gecko/20100818 Firefox/4.0b4

The Linux version of the user agent still has the two fields:
Mozilla/5.0 (X11; Linux i686; rv:2.0b4) Gecko/20100818 Firefox/4.0b4

If I remove the X11; part then I get the mobile version as well.

Comment 3

8 years ago
Currently only the Windows platform is affected:

Mozilla/5.0 (X11; Linux i686; rv:2.0b4) Gecko/20100818 Firefox/4.0b4
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b4) Gecko/20100818 Firefox/4.0b4
Mozilla/5.0 (Windows NT 6.0; rv:2.0b4) Gecko/20100818 Firefox/4.0b4

With more changes on the way, I would assume that it is not possible yet for Google to fix this problem.

Bug 581783 - Remove "Windows;" from the UA string
Bug 589353 - Reformat platform-specific bits of UA string
Bug 572650 - (http-fingerprint) Reduce the amount of data and entropy sent out in HTTP requests (meta bug)
(Reporter)

Comment 4

7 years ago
Marking WORKSFORME to get this off my bug list. Looks like the issue was fixed a looong time ago.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.