Closed Bug 591325 Opened 10 years ago Closed 10 years ago

fix additional chrome style tests which fail when run from a .jar package and minor cleanup

Categories

(Testing :: General, defect)

x86
Linux
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: jmaher, Assigned: jmaher)

References

Details

Attachments

(1 file, 3 obsolete files)

in bug 574189 the heavy lifting was done for the large majority of tests.  There are a few small test cases that need work or have simple errors that we should fix.

Also from bug 586754 there are some comments that need to be resolved in config/rules.mk.
Assignee: nobody → jmaher
Blocks: 543800
Attached patch additional test cleanup (1.0) (obsolete) — Splinter Review
simple patch to cleanup errors and a few tests which need to be fixed while running as a .jar.
Attachment #469860 - Flags: review?(ctalbert)
Comment on attachment 469860 [details] [diff] [review]
additional test cleanup (1.0)

This looks good.  You verified that the mockObjects.js is self-contained enough to run from simpleTests right?  Cause if it references anything in that original directory it used to be in, that will fail.

r=ctalbert with that addressed.
Attachment #469860 - Flags: review?(ctalbert) → review+
Attached patch additional test cleanup (2.0) (obsolete) — Splinter Review
updated with more tests and fixed a bug in the mockObject.js mochitest-plain usage (we needed to add netscape.* permissions to mockObject since it is running in normal mode, not chrome).

try server run is underway
Attachment #469860 - Attachment is obsolete: true
Attachment #471860 - Flags: review?(ctalbert)
ok, an error on windows, I will update here when I have a working patch...should know sometime tomorrow with try server runs and all.
Attached patch additional test cleanup (3.0) (obsolete) — Splinter Review
latest patch fixes issues with rtlchrome test_bug437844.html on windows with slash direction in javascript and windows.

This passes on try server!
Attachment #471860 - Attachment is obsolete: true
Attachment #472207 - Flags: review?(ctalbert)
Attachment #471860 - Flags: review?(ctalbert)
ok, this wasn't passing on XPCSHELL tests for the weekend run due to a test that has a hardcoded date in a test file.  So now this depends on bug 594011 in order to land and keep xpcshell green.

This also cleans up some additional browser chrome tests that I had overlooked in running from a .jar.
Attachment #472207 - Attachment is obsolete: true
Attachment #472737 - Flags: review?(ctalbert)
Attachment #472207 - Flags: review?(ctalbert)
Comment on attachment 472737 [details] [diff] [review]
additional test cleanup (3.1)

feedback+ for rules.mk change.  Looks good.
Attachment #472737 - Flags: feedback+
Comment on attachment 472737 [details] [diff] [review]
additional test cleanup (3.1)

This looks good, I believe it addresses the relativesrcdir regression as well.
Attachment #472737 - Flags: review?(ctalbert) → review+
http://hg.mozilla.org/mozilla-central/rev/47c6a53ffd8c
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
Blocks: 603866
You need to log in before you can comment on or make changes to this bug.