Black Tab Thumbnail previews

VERIFIED FIXED

Status

VERIFIED FIXED
8 years ago
8 years ago

People

(Reporter: tchung, Unassigned)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
Created attachment 469907 [details]
Black tab thumbnails

Dupe me if already known.  Not all sites, but there are still a lot of pages that load properly, but still display the thumbnails in the tab sidebar as black.  

See screenshot.  Applies to both Android and Maemo builds

Repro:
1) install android and maemo nightlies:  
- Mozilla/5.0 (Android; Linux armv7l; rv:2.0b5pre) Gecko/20100826 Namoroka/4.0b5pre Fennec/2.0a1pre
- Mozilla/5.0 (X11; U; Linux armv7l; en-US; rv:2.0b4pre) Gecko/20100826 Namoroka/4.04pre Fennec/2.0a1pre
2) Open a few tabs and visit a few urls.  check that they are full loaded
3) scroll over to tab view pane, and verify some of them preview black thumbnails.

Expected:
- no black thumbnails if the page has loaded content

Actual:
- black thumbnails
(Reporter)

Updated

8 years ago
tracking-fennec: --- → ?
I'm having trouble reproducing this now, but in the past I have seen it along with an error in the console from asyncDrawXULElement in browser.js (rendererFactory).
I believe that we will be switching to -moz-element for thumbnails in the near future which will change the code that handles this significantly and should be more robust.

can someone from the FE team confirm that?
It will will be -moz-element or drawWindow (which will leverage layers as well, see bug 590525).  -moz-element probably doesn't work right now, and it isn't a target for b1 from what I understand from Chris Jones.

Comment 4

8 years ago
Build: Mozilla/5.0 (Android; Linux armv7l; rv:2.0b5pre) Gecko/20100826
Namoroka/4.0b5pre Fennec/2.0a1pre

Here is something I experienced:

I opened yahoo.com in a tab. I opened a new tab. I opened yahoo.com again in a new tab and opened the tab side bar as soon as the page started loading. After the webpage was loaded, I could see that half the tab thumbnail was white and half was the webpage view. So fwiw, tony mentioned in comment#1 about black thumbnail whereas I saw half white and half webpage. 
So, is my case a part of this same functional bug or is this something different than what this bug is for?
tracking-fennec: ? → 2.0b2+
Depends on: 576192
Seems to be fixed for me. After opening 10 tabs, no black thumbnails.

fixed by bug 576192
Status: NEW → RESOLVED
tracking-fennec: 2.0b2+ → 2.0b1+
Last Resolved: 8 years ago
Resolution: --- → FIXED
verified FIXED on builds:

Mozilla/5.0 (Maemo; Linux armv71; rv:2.0b6pre) Gecko/20100916 Namoroka/4.0b7pre Fennec/2.0b1pre

and

Mozilla/5.0 (Android; Linux armv71; Nokia N900; en-US; rv:2.0b6pre) Gecko/20100916 Namoroka/4.0b7pre Fennec/2.0b1pre
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.