XML/XSL rendering after using Panorama fails

VERIFIED FIXED in Future

Status

defect
P5
normal
VERIFIED FIXED
9 years ago
3 years ago

People

(Reporter: aevargareg, Assigned: sicking)

Tracking

({regression})

unspecified
Future
x86
Windows XP
Dependency tree / graph

Firefox Tracking Flags

(blocking2.0 betaN+)

Details

(Whiteboard: [softblocker])

Attachments

(2 attachments)

Reporter

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows NT 5.1; rv:2.0b4) Gecko/20100818 Firefox/4.0b4 ( .NET CLR 3.5.30729; .NET4.0C)
Build Identifier: Mozilla/5.0 (Windows NT 5.1; rv:2.0b4) Gecko/20100818 Firefox/4.0b4 ( .NET CLR 3.5.30729; .NET4.0C)

I have my homepage set to a local XML file.  When I create a tab group using a couple of Internet URL's, then open a new tab and click the icon for my home page, the URL displays in the address bar but the page does not load.  A local HTML file is not a problem, only an XML file.

Reproducible: Always

Steps to Reproduce:
1.Set homepage to a local XML file.
2.Navigate to an external website.
3.Open a second tab and to go another external website.
4.Create a tab group.
5.Press Escape to open a new tab.
6.Click the Home icon in the toolbar.
Actual Results:  
The URL displays in the address bar, but the rest of the screen is blank.  Either the file type is not allowed, or it never finishes loading.  Clicking the Refresh icon has no effect.

Expected Results:  
The XML file should have displayed.
Component: Tabbed Browser → TabCandy
QA Contact: tabbed.browser → tabcandy

Comment 1

9 years ago
Mozilla/5.0 (Windows NT 6.1; rv:2.0b7pre) Gecko/20100914 Firefox/4.0b7pre

Unable to reproduce. I am able to see the XML file after step 6.
Reporter

Comment 2

9 years ago
I just confirmed this issue with:
Mozilla/5.0 (Windows NT 5.1;rv2.0b6)
Gecko/20100101 Firefox/4.0b6

I originally reported this from work behind a corporate firewall and using a proxy to connect to the Internet.  I just tried again from home with no proxy.

With all of the concern surrounding XSL stylesheets, I made a copy of my original XML file and modified the stylesheet reference to a copy of the XSL in the same folder.  There was no change in behavior.

Let me know if you want me to upload both the XML and XSL files for testing.
Alan, if you could upload those files you're using, that may be helpful.
Priority: -- → P5
Reporter

Comment 4

9 years ago
Posted file data file
ML data file to be used as FF home page; XSL stylesheet also uploaded
Reporter

Comment 5

9 years ago
used to style homepageatwork_copy.xml
Alan, can you look at bug 592970? I think this bug might be a dupe of that one.

Comment 7

9 years ago
This is a very strange bug (especially with all of the stuff from bug 592970). Unfortunately, we are going to have to punt here until after Firefox 4—we have higher impact bugs and this seems like a highly volatile thing to try and debug.

We would *love* a patch, though.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Cannot use local XML file as home page when using tab groups. → XML/XSL rendering after using Panorama fails
Target Milestone: --- → Future

Updated

9 years ago
Duplicate of this bug: 592970
Aza, would it be worth marking this as something like Core, or ccing people, so that XML display people can look at this? While this is clearly a Panorama bug, I for one wouldn't know how to even start looking into this.

Comment 10

9 years ago
As noted in bug 592270, and with
 further testing:

http://www.w3schools.com/xsl/xsl_transformation.asp

is another example  (Minefield Windows7)
look for the "View results" link on the page,  whether the XML table is
displayed depends on how the link is clicked - 

-right click, select "Display in new Window"   always works

-right click, select "Display in new tab"   always works

-click on link gives new tab (the default Firefox setting in "Options" for how
to open links is 'Open in new tab')  -does NOT work once Panaroma has been used/shown - gives a blank tab.  Does work before Panorama shown.

Something in the way the tab is created is the problem.

Comment 11

9 years ago
(In reply to comment #10)
> As noted in bug 592270, and with
>  further testing:
> 
> http://www.w3schools.com/xsl/xsl_transformation.asp
> 
> is another example  (Minefield Windows7)
> look for the "View results" link on the page,  whether the XML table is
> displayed depends on how the link is clicked - 
> 
> -right click, select "Display in new Window"   always works
> 
> -right click, select "Display in new tab"   always works
> 
> -click on link gives new tab (the default Firefox setting in "Options" for how
> to open links is 'Open in new tab')  -does NOT work once Panaroma has been
> used/shown - gives a blank tab.  Does work before Panorama shown.
> 
> Something in the way the tab is created is the problem.

Sorry other bug was 592970

Comment 12

9 years ago
This bug does not occur when open in background, 
I think the cause is a timing of canvas drawWindow().
In case of loading tab is a background tab, TabCanvas.prototype.point method is not called until the tab is selected or Panorama is shown.
Jonas, this might be a way to reproduce the XSLT thing...  Does this really belong in Firefox?
blocking2.0: --- → ?
This definitely blocks. If someone has a valid URL as their homepage, we must load it in the browser.
blocking2.0: ? → betaN+
This may be related to bug 609685; let's see if that patch fixes this.
Depends on: 609685

Updated

9 years ago
Keywords: regression
Assignee: nobody → jonas
Whiteboard: [softblocker]
softblocker = critical
Severity: normal → critical
Severity: critical → normal
bug 609685 has now landed… has it fixed this bug as well?
Also, Jonas, are you still planning on working on it (if it's still present)?

Updated

9 years ago
Duplicate of this bug: 626417

Comment 20

9 years ago
I just retested bug 626417 which didn't work with a build from 2 days ago, but works with last nights build.  This seems to work fine now.  I noticed that CTRL+E no longer works to bring up the tab groups though.
(In reply to comment #20)
> I noticed that
> CTRL+E no longer works to bring up the tab groups though.

The shortcut was changed to shift+ctrl+E.
Works for me with latest nightly. Can anyone please confirm so that we can close this blocker?
Marking FIXED based on previous comment.

Alan: If you're still seeing problems, please reopen this bug.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Reporter

Comment 24

9 years ago
I just downloaded and installed firefox-4.0b10pre.en-US.win32.installer.exe dated 2011-01-19 and reran my test case.  I agree, the problem is resolved.  Thanks everyone!
Marking VERIFIED per previous comment.
Status: RESOLVED → VERIFIED
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.