venkman/firefox freeze while debugging, requires kill

RESOLVED INVALID

Status

Other Applications
Venkman JS Debugger
--
critical
RESOLVED INVALID
7 years ago
7 years ago

People

(Reporter: alta88, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
a single breakpoint is set in a function called by a menupopup's onpopupshowing attribute, in form myFunc(event, this).  after the breakpoint hits, an immediate F5 Continue is issued, ending debugging.  after 1-2 seconds venkman/firefox are frozen.

if an F5 is not issued, ie while trying to inspect vars etc., then after 1-2 seconds the same freeze happens also.

venkman 0.9.88.1 and today's trunk build.

Comment 1

7 years ago
Can you provide more specific steps to reproduce? With the information in your description alone, I can't reproduce this, nor track down what the problem is.

Furthermore, does the same thing happen with 3.6.8 and/or the last Fx4 Beta?
(Reporter)

Comment 2

7 years ago
from a very quick test, it did not happen in 3.6 with my extension, but i can definitely recreate it in:
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b5pre) Gecko/20100827 Minefield/4.0b5pre.

a better str:
1)start the debugger.
2)set a breakpoint in browser.js, function contentAreaClick, line 9056.
3)rt click on an new/empty tab and wait for the debugger to stop at the bp.
4)wait 5 or so seconds, or expand a variable object.

i can recreate at will, sometimes the debugger doesn't even get to the bp before the hang.  very minimal extensions, just domi, console2, addon compat reporter.  only thing in console is a venkman css warning; there are no cpu cycles expended.  let me know if there's some other diagnosis to do, though i think going back to various betas for regression is probably not too efficient..
(Reporter)

Comment 3

7 years ago
closing, as this no longer happens, but still no debugger as bug 614557 hasn't gone anywhere.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.