Firefox browsing window disappears permanently with no cause

RESOLVED WORKSFORME

Status

()

Firefox
General
--
critical
RESOLVED WORKSFORME
7 years ago
6 years ago

People

(Reporter: ruzkahusky, Unassigned)

Tracking

4.0 Branch
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [testday-20120413])

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_6_4; en-us) AppleWebKit/533.17.8 (KHTML, like Gecko) Version/5.0.1 Safari/533.17.8
Build Identifier: 4.04b

The best way I can describe this is that occasionally firefox will launch but there will be no window and no means of getting a window to appear. Now if I go to the window menu option it will say there is a session open  but there is no window displaying my home page or anything.
*The only fix I can come up with is to completely uninstall all files and delete every .plist or other file ever related to firefox, then re-download and start over again.
All passwords are lost and so are all bookmarks.
This also happens with the downloads window.

This also happened once on the last build.


Reproducible: Couldn't Reproduce

Comment 1

7 years ago
This seems to be a newly frequent issue:

see also bugs 593032, 589969, 591532, 591176

Before I dupe, I'd like some more info:

Reporter, can you answer the following:

What version of Firefox did you FIRST see this happening in (Firefox 4 betas, 3.6, 3.5?)
Did you recently apply an OSX software update? Can you also tell me your OS version (Go to the Apple menu > About this Mac, click More Info and select Software from the left menu.) What is the full System Version? It should start Mac OS X 10.6.4 but I need the bit after that.
Do you regularly connect your mac up to a second monitor? When this happened, was this monitor connected?

Thanks!

(I'm sorry you lost all your data, but if you could answer the above questions, I'd like to stop this from happening to anyone else.)
(Reporter)

Comment 2

7 years ago
I saw this first in the Firefox 4 Beta, I did not update before it happened my current OS X version is: 10.6.4 (10F569)
Yes I do connect it to a second monitor regularly but it seemed to happen after I unplug the monitor, again it does not always happen and has yet to happen again. It is very odd.
Sorry I did not include all the needed information the first time, sorry to inconvenience you.

Updated

7 years ago
Version: unspecified → 4.0 Branch
This bug was reported using a pre-release version of Firefox 4. Now that Firefox 4.0.1 final has been released, can you please update and retest your bug? A fresh profile would be a good starting place to test, 
http://support.mozilla.com/kb/Managing+profiles. If you continue to see the issue, can you please update this bug with your results?

Filter: firefox4prebugsunco
cant reproduce on Firefox 11, 12b4,13 and 14

for support, please ask question in https://support.mozilla.org/questions/new
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
Whiteboard: [testday-20120413]
You need to log in before you can comment on or make changes to this bug.