Firefox always creates a 'Downloads' folder in My Documents

RESOLVED DUPLICATE of bug 474718

Status

()

RESOLVED DUPLICATE of bug 474718
8 years ago
8 years ago

People

(Reporter: grnhornet, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; fi; rv:1.9.2.8) Gecko/20100722 Firefox/3.6.8
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; fi; rv:1.9.2.8) Gecko/20100722 Firefox/3.6.8

Firefox 3.6.8 and Firefox 4 beta versions always creates a 'Downloads' folder in My Documents even if some other download folder is set in the Firefox settings.

On newer Windows versions the Downloads folser in My Documents is a system folder and it should always exist, but on older systems Firefox shouldn't enforce creation of this folder.

Reproducible: Always

Steps to Reproduce:
1. Set Firefox download folder to some other folder than 'My Documents\Downloads'.
2. Close Firefox and delete 'My Documents\Downloads' folder if it exist.
3. Start Firefox and go to to options and view the General settings tab where you can change the download folder.
Actual Results:  
Downloads folder is created in My Documents.

Expected Results:  
Firefox shouldn't create the 'My Documents\Downloads' folder as download folder is set to different folder in Firefox settings.

Just viewing the General settings tab in Firefox options dialog will create 'Downloads' folder. Firefox doesn't seem to create this folder on other occasions.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 474718
You need to log in before you can comment on or make changes to this bug.