First app tab is not clickable when moving the mouse to the leftmost position

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
8 years ago
5 years ago

People

(Reporter: floele, Unassigned)

Tracking

Trunk
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b4) Gecko/20100818 Firefox/4.0b4 ( .NET CLR 3.5.30729; .NET4.0E)
Build Identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b4) Gecko/20100818 Firefox/4.0b4 ( .NET CLR 3.5.30729; .NET4.0E)

When creating an app tab, which is, compared to other tabs, rather small, it is not possible to select the first (that is, leftmost) tab by moving the mouse to the leftmost position inside the window (easier to notice if window is maximised).


Reproducible: Always

Steps to Reproduce:
1. Create an app tab in maximised window.
2. Move mouse to the leftmost position, at the same height as the tab bar.
3. Click.
Actual Results:  
App tab is not selected.

Expected Results:  
First app tab is selected.

It is easier to select the app tab, if the clickable area of the tab is extended to an "infinite" area left to it. (Compare to the Windows Start button, which extends to the leftmost and bottommost point of the screen.)
Whiteboard: dupeme
Version: unspecified → Trunk

Comment 1

8 years ago
Build identifier: Mozilla/5.0 (Windows NT 6.1; rv:2.0b10pre) Gecko/20110117 Firefox/4.0b10pre

I am not sure if that is the expected behavior. Maybe issue should be changed to enhancement.

Comment 2

8 years ago
I believe this has been resolved now with recent Firefox's. 

Cases:
1) Menu bar hidden, Firefox menu shown, tabs are drawn in titlebar: Moving mouse to leftmost part of screen should activate Firefox menu, not app tab. Works as expected.

2) Menu bar hidden, Firefox menu shown, tabs NOT drawn in titlebar: Moving mouse to leftmost part of screen activates the leftmost app tab. Works as expected.

3) Menu bar shown: Moving mouse to leftmost part of screen activates the leftmost app tab. Works as expected.

If I'm not missing something, this bug has been resolved?
(Reporter)

Comment 3

8 years ago
Yep, I'd agree. Does no longer apply to 4.0 final.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED

Updated

8 years ago
Resolution: FIXED → WORKSFORME

Updated

5 years ago
Whiteboard: dupeme
You need to log in before you can comment on or make changes to this bug.