Account Manager (and other screens) exceed display size and become unusable

RESOLVED FIXED in Thunderbird 3.3a1

Status

MailNews Core
Account Manager
RESOLVED FIXED
7 years ago
6 years ago

People

(Reporter: Beverly Howard, Assigned: InvisibleSmiley)

Tracking

({access})

Trunk
Thunderbird 3.3a1
access

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.22) Gecko/20090605 SeaMonkey/1.1.17
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.22) Gecko/20090605 SeaMonkey/1.1.17

I fall into the "Aged and Vision Impaired" category, so, this bug falls into
the "serious" category for me.

When when users with vision problems set the display options to font settings large enough to make the screen readable (for example, 150 DPI) SeaMonkey and Tunderbird presents the user with a serious problem trying
to use the "Mail and Newsgroups Account Settings" screen.

The Account Manager (and other) screens have no "sizing" options and, at the 150DPI setting the window size significantly exceeds the size of the screen.

The default problem is that you cannot get to the "OK, Cancel, Help" buttons. 
The only option for me was to select the <M>ove option to move the bottom edge
of the window over to my second monitor.

Then it get's crazy.  SM "remembers" the screen position and the next time this
window is opened, it opens with the buttons visible, but the top of the screen
inacessbile.  At that point, the only option is to remember that <Alt-space>
brings up the "Move" menu, and <M> then allows you to drag the window to get to
the top fields.

The simple solution would be to assure that _all_ windows have scroll bars and
sizing options and to not assume that the os platform offers access options.

A reduced sized screen shot at http://bevhoward.com/stuff/images/OverSize.gif
shows how the mail settings window is clipped when opened in the 1920x1080
monitor with the XPPro display font setting at 150 DPI.

This problem has been extensively discussed without resoluton at;

https://bugzilla.mozilla.org/show_bug.cgi?id=416263 

https://bugzilla.mozilla.org/show_bug.cgi?id=516586 

The second bug (516586) states that this problem is
"resolved" ...that statement seems to be as a result of not being able to
reproduce the problem.  This is kernel issue and it is reproducible in
different platforms and different versions.

Thanks in advance for any consideration to this problem.
Beverly Howard

=====related information=====

Ironically, using a large high resolution monitor (mine is a 23" LCD TV set at
1920x1080) creates a large number of font readability problems, and, over the
years, I have learned how to deal with most of them.

One basic step to assist the vision impaired is to set the display
properties/settings/advanced/DPI to "Large size (120 dpi)"  Recently, even this
has proven to be insufficient for my vision, so, in order to meet my vision
needs, I recently set this to a "custom" value of 150DPI.




Reproducible: Always

Steps to Reproduce:
1.On Windows (XPPro for example) 

display properties/settings/advanced/DPI

set to "Custom size (150 dpi)"

2. Open email client, the edit/mail and newsgroup account settings

3. This is a single scenario... problem can occur in a variety of circumstances and at other standard dpi settings such as on small screen computers such as netbooks.
Actual Results:  
the screen buttons are not accessible

In some cases

Expected Results:  
to be able to use screens

provide window resize options in order to cope with the problem.
(Reporter)

Comment 1

7 years ago
Shared code segment

http://mxr.mozilla.org/comm-central/source/mailnews/base/prefs/content/accountUtils.js#243
(Reporter)

Comment 2

7 years ago
Comment received from Jans Hatlak <jh@junetz.de>

BTW: A quick check confirmed my guess that the code in question is currently shared:
<http://mxr.mozilla.org/comm-central/source/mailnews/base/prefs/content/accountUtils.js#243>

Adding "resizable" to the comma-separated list (third parameter) of the openDialog call is all that is needed to fix this bug.

Since this is a simple JavaScript function it could be forked (copied/renamed/adapted in SeaMonkey-specific code) easily. Again this is not a technical problem but one concerning agreement of the decision-takers (called reviewers). We usually try to go with a solution for both applications (even if that means that we get a No after two months as just happened on bug 465116). If a cross-app solution is not wanted we try to do a SM-only fix.

Greetings,

Jens
(Reporter)

Comment 3

7 years ago
Comment received from Jans Hatlak <jh@junetz.de>

BTW: A quick check confirmed my guess that the code in question is currently shared:
<http://mxr.mozilla.org/comm-central/source/mailnews/base/prefs/content/accountUtils.js#243>

Adding "resizable" to the comma-separated list (third parameter) of the openDialog call is all that is needed to fix this bug.

Since this is a simple JavaScript function it could be forked (copied/renamed/adapted in SeaMonkey-specific code) easily. Again this is not a technical problem but one concerning agreement of the decision-takers (called reviewers). We usually try to go with a solution for both applications (even if that means that we get a No after two months as just happened on bug 465116). If a cross-app solution is not wanted we try to do a SM-only fix.

Greetings,

Jens

Comment 4

7 years ago
Support For SeaMonkey 1.x Dropped, see ( http://www.seamonkey-project.org/news#2010-03-16 or http://weblogs.mozillazine.org/seamonkey/archives/2010/03/support_for_sea.html ).

Reporter, can you try and reproduce with SeaMonkey v2.0.6 or 2.1a3? (2.1a3 isn't stable enough for everyone's daily use yet).
Version: unspecified → SeaMonkey 1.1 Branch
(Assignee)

Comment 5

7 years ago
This is valid for the 2.0 branch as well and still valid for trunk.
Version: SeaMonkey 1.1 Branch → Trunk
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: access
(Assignee)

Comment 6

7 years ago
Created attachment 470305 [details] [diff] [review]
make Account Manager resizable on all platforms [Checkin: comment 15]

This patch makes the Account Manager resizable on all platforms, for SM and TB. It then behaves the same as SM's Preferences window (TB's is not resizable, matching FF's, but then they are similar to each other but different to SM's). The size is not persisted, again like SM's Preferences window.

I'll try my luck with a shared fix for (currently) shared code.

Mnyromyr, please let us know what you think for SM even in case TB doesn't want this. We'd just have to write our own function then, or make the existing one accept a parameter and adapt our call.

I'll take the bug if I get at least one positive review.
Attachment #470305 - Flags: superreview?(bugzilla)
Attachment #470305 - Flags: review?(mnyromyr)
Assignee: nobody → jh
Component: MailNews: Account Configuration → Account Manager
Product: SeaMonkey → MailNews Core
QA Contact: mailnews-account → account-manager
Comment on attachment 470305 [details] [diff] [review]
make Account Manager resizable on all platforms [Checkin: comment 15]

I think this would be worth considering - but that's more Bryan's call than mine.

My main concern here would be what happens when you decrease the size of the account manager display - does it decrease in size appropriately and have a minimum size etc
Attachment #470305 - Flags: superreview?(bugzilla) → ui-review?(clarkbw)
(Reporter)

Comment 8

7 years ago
OP observations to responses to date;

>> decrease the size of the account manager display <<

As a programmer (in another language) I understand this concern, but, in this case the problem is vertical plus there is both adequate horizontal real estate
as well this fix giving the ability to address extreme handicap needs.  Adding the control will significantly decrease real estate only when the scroll bars are needed.

In the same vein, it is impossible for any, or for that fact, many programmers to experience and test all of the eventualities of hardware, platform, settings and biological needs, so, it's hard to understand any reluctance to give users the ability to cope when issues not considered in design are encountered.

>> edit/preferences <<

imho, this bug consideration should not be limited to the mail account screen.  The edit/preferences screen is only slightly smaller and it is also generating problems on small screen platforms such as netbooks, especially when those with vision problems attempt to address their needs by increasing font size settings.  I already anticipate that I will have the need to exceed my current 150dpi setting.

>> accessibility <<

Working with my own limits as well as having worked with many who have accessibility issues, I feel very strongly that any issues that have potential to not only increase accessibility, but to make the platform comfortable for those with handicaps to use should be given an additional consideration column.

Historically, software is generated by young programmers who begin their work with excellent vision and good health which tends to bypass consideration for those who may not have the same, but, imho, should be included as a constant factor in design decision processes.

Thanks for your consideration to these (and other) needs,
Beverly Howard
Comment on attachment 470305 [details] [diff] [review]
make Account Manager resizable on all platforms [Checkin: comment 15]

I think this is worth trying though I haven't had a chance to test it out yet.  I don't think our account manager will look very good when sized smaller but I'm not too concerned about that problem.
Attachment #470305 - Flags: ui-review?(clarkbw) → ui-review+
(Reporter)

Comment 10

7 years ago
>> I don't think our account manager will look very good when sized smaller <<

fwiw, the size does not need to change... the "sizability" simply allows the window to be usable (scrollable) when it exceeds the user's display size.

Beverly Howard
(Assignee)

Updated

7 years ago
Attachment #470305 - Flags: superreview?(neil)
Comment on attachment 470305 [details] [diff] [review]
make Account Manager resizable on all platforms [Checkin: comment 15]

I'm not actually convinced that this fixes the bug as described...

>+                          "AccountManager", "chrome,centerscreen,modal,titlebar,resizable",
Nit: needs to be split onto two lines
Attachment #470305 - Flags: superreview?(neil) → superreview+
(Reporter)

Comment 12

7 years ago
As the OP it's been interesting to watch this thread but it has been frustrating to the point of regretting that I posted the problem.

This design problem is a very long standing and very discussed problem issue for a significant percentage of mozilla users for years.  At the moment, there are scenarios where there are _no_ options for the user such as my needing to use my 1024x768 laptop undocked this week and found that with the windows settings rolled back to "large fonts" not only is the mail account settings window not usable, "Preferences" is not usable.

While I understand that the "best" fix is the most desirable, please take a moment to consider that continuing with "no options" for the _users_ needs to be addressed even if implimenting "resizable" is not that "best" option.

We (the users) don't have to have cake... a crumb or two will do.

Very sincerely,
Beverly Howard
(Assignee)

Comment 13

7 years ago
(In reply to comment #12)
> While I understand that the "best" fix is the most desirable, please take a
> moment to consider that continuing with "no options" for the _users_ needs to
> be addressed even if implimenting "resizable" is not that "best" option.

Bugzilla can be confusing at times: While the reviewers have voiced their concerns, they still gave a positive review. Now if Mnyromyr also gives a positive review or chooses to opt out, this will be fixed despite those concerns.
Comment on attachment 470305 [details] [diff] [review]
make Account Manager resizable on all platforms [Checkin: comment 15]

I've always hated non-resizable windows, especially back in my Windows days. 
(My current window manager doesn't care anyway.)
Attachment #470305 - Flags: review?(mnyromyr) → review+
(Assignee)

Updated

7 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 15

7 years ago
Comment on attachment 470305 [details] [diff] [review]
make Account Manager resizable on all platforms [Checkin: comment 15]

http://hg.mozilla.org/comm-central/rev/9fe106124149
Attachment #470305 - Attachment description: make Account Manager resizable on all platforms → make Account Manager resizable on all platforms [Checkin: comment 15]
(Assignee)

Updated

7 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 3.3a1

Comment 16

6 years ago
Mozilla/5.0 (Windows NT 5.1; rv:7.0) Gecko/20110922 Thunderbird/7.0

This is NOT fixed.  

I went to the Thunderbird menu bar and selected [Tools > Account Settings].  The resulting Account Settings window was too high, with the title bar unreachable above the top of my monitor.  Thus, I could not drag the window down.  

I again went to the Thunderbird menu bar and selected [Tools > Account Settings].  This time, the bottom of the resulting Account Settings window was too low, with the OK and Cancel buttons below the bottom of my monitor.  Since the title bar was now visible, I used it to resize the Account Settings window by dragging the top downward and then dragging the whole window upward.  Now the OK and Cancel buttons hide the Manage Identities button.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(In reply to David E. Ross from comment #16)
> This is NOT fixed.  

Something was fixed and was changed and this has been in released software for quite a while now. Please file a new bug with your issues.
Status: REOPENED → RESOLVED
Last Resolved: 7 years ago6 years ago
Resolution: --- → FIXED

Comment 18

6 years ago
See bug #700039.
You need to log in before you can comment on or make changes to this bug.