download of newsgroups headers takes too long

VERIFIED WORKSFORME

Status

MailNews Core
Backend
P3
normal
VERIFIED WORKSFORME
18 years ago
10 years ago

People

(Reporter: matthias tarasiewicz, Assigned: scottputterman)

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows 98; Win 9x 4.90)
BuildID:    20001103

when trying to subscribe to newsgroups, mozilla seems to download all the 
header information every time i open the subscribe window -- solution: mozilla 
should store the information and then only check for new groups if requested

Reproducible: Always
Steps to Reproduce:
1. select "subscribe to newsgroups" in the news/ mail part
2. see for yourself
3.

Actual Results:  this shows a problem with storing the header information- the 
performance is much too slow compared with other newsreaders 

Expected Results:  it should be fixed (maybe mozilla should save all the header 
information locally and then search this local file and only check for new 
newsgroups if requested by the user)

Comment 1

18 years ago
I agree. Mozilla is too slow in initially loading the newsgroup
list and when the subcribe menu is engaged thereafter.

I am sure, though, that this is a known problem and there must
be a prior bug for which this is a duplicate.
Also this is not a localization or internationalization bug.
To putterman ... and mail QA people (esther and laurel)
Status: UNCONFIRMED → NEW
Component: Localization → Mail Back End
Ever confirmed: true
QA Contact: momoi → laurel

Comment 2

18 years ago
This time really sending it to scott.
Assignee: rchen → putterman

Comment 3

17 years ago
it's actually pretty fast now.
btw: there's another bug for the support of "new" newsgroup. Can remember the
bug number.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME

Updated

17 years ago
QA Contact: laurel → stephend
This seems to be okay for me, although we have a bug out on larger servers'
subscribe window taking a long time to appear.  Matthias, is this much better
than when you filed it?
We don't download headers in the subscribe window, we're just building the list
of newsgroups from the server.  This seems much better to me, too (than when I
first started in November of 2000).  We also have bug 73501 outstanding, which
you might want to take a look at.  Bug 40260 covers New newsgroups appearing in
the Subscribe window.

Verified.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.