'Set up Sync' UI has a problem with 'next field' after user name

RESOLVED WORKSFORME

Status

Cloud Services
Firefox Sync: UI
RESOLVED WORKSFORME
8 years ago
8 years ago

People

(Reporter: stuart, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.0; rv:2.0b4) Gecko/20100818 Firefox/4.0b4 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows NT 6.0; rv:2.0b4) Gecko/20100818 Firefox/4.0b4 (.NET CLR 3.5.30729)

Tools > Set up Sync > I've never used sync before

TAB > sends to the second field (username).
If you enter a SHORT username, THEN: TAB sends to the PASSWORD field (OK)
If you enter a LONG username (say 16 characters), then TAB does NOT send to the next field, but instead rotates briefly through the 'connect to' field before generating an 'Unknown Error'.
Interestingly: if you FIRST input a SHORT username, TAB through, and only THEN input a LONG username ... the 'next field' TAB works?!
Good luck!

Reproducible: Always

Steps to Reproduce:
1. Tools > Set up Sync > I've never used Sync before
2. TAB
3. Enter LONG username (say 15 characters)
4. TAB sends back to the 'select server' field.
5. Press and hold (repeat) TAB.
Actual Results:  
Unknown Error report generated

Expected Results:  
Next field

As per details.

Good luck guys!

Hmmm - it seems that there is a maxlength for username+password - even if you CLICK into the password field, after a few characters the error is repeated.

Updated

8 years ago
Component: General → Firefox Sync: UI
Product: Firefox → Mozilla Services
QA Contact: general → sync-ui
(In reply to comment #0)
> If you enter a LONG username (say 16 characters), then TAB does NOT send to the
> next field, but instead rotates briefly through the 'connect to' field before
> generating an 'Unknown Error'.

I can't reproduce this. FWIW, the brief UI blocking when you leave the username field is being fixed.

> Hmmm - it seems that there is a maxlength for username+password - even if you
> CLICK into the password field, after a few characters the error is repeated.

There's a max length for usernames, 32 characters. I can't reproduce the errors you're seeing for 15 or 16 characters, though.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.