Tabs from storage should be placed in their proper group immediately on tab view load, not moved there later

RESOLVED DUPLICATE of bug 590268

Status

defect
RESOLVED DUPLICATE of bug 590268
9 years ago
3 years ago

People

(Reporter: mitcho, Unassigned)

Tracking

Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Watching the tab view load with more than a dozen or two tabs open in different groups, I noticed that many tabs were being grouped into a single group at first, and then slowly get moved into their actual groups.

Maybe this is just me (or just my storage state? :/) but this should not happen.
This seems to only happen when the tab view is loaded immediately on Firefox startup, and it seems to happen because storage data for the tab is not found in TabItem.reconnect during reconstitution (TabItems.link) but *is* found during the subsequent update (TabItems.update). hmm....
(In reply to comment #1)
> This seems to only happen when the tab view is loaded immediately on Firefox
> startup, and it seems to happen because storage data for the tab is not found
> in TabItem.reconnect during reconstitution (TabItems.link) but *is* found
> during the subsequent update (TabItems.update). hmm....

This isn't quite right: instead, it's the "attrModified" event which is triggering the proper reconnect. Perhaps we should use SSTabRestoring instead, which marks the earliest possible time when we can get storage data?
This is the purpose for Bug 590268.  Note that this work depends on Bug 578512.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 590268
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.