Import and Export is broken [Exception "Component returned failure code: 0x80570016 (NS_ERROR_XPC_GS_RETURNED_FAILURE) [nsIJSCID.getService]"]

RESOLVED FIXED in 1.0b4

Status

defect
--
major
RESOLVED FIXED
9 years ago
9 years ago

People

(Reporter: ssitter, Assigned: Fallen)

Tracking

Trunk
1.0b4
Bug Flags:
blocking-calendar1.0 +

Details

(Whiteboard: [needed beta][no l10n impact])

Attachments

(2 attachments)

(Reporter)

Description

9 years ago
Lightning 1.1a1pre (BuildID: 20100829013809) with Mozilla/5.0 (Windows NT 6.1; rv:2.0b5pre) Gecko/20100827 Thunderbird/3.2a1pre (BuildID: 20100827033932)

Steps to reproduce:
1. Create clean Thunderbird profile, install Lightning, restart
2. Create at least one event in the calendar
3. Select menu command Events and Tasks > Export/Import

Actual Result: Export/Import fails.

Error on Import:
[[[
Error: An error occurred executing the calendar_import_command command: [Exception... "Component returned failure code: 0x80570016 (NS_ERROR_XPC_GS_RETURNED_FAILURE) [nsIJSCID.getService]"  nsresult: "0x80570016 (NS_ERROR_XPC_GS_RETURNED_FAILURE)"  location: "JS frame :: chrome://calendar/content/import-export.js :: loadEventsFromFile :: line 82"  data: no]
Source File: chrome://global/content/globalOverlay.js
Line: 100
]]]

Error on Export:
[[[
Error: [Exception... "Component returned failure code: 0x80570016 (NS_ERROR_XPC_GS_RETURNED_FAILURE) [nsIJSCID.getService]"  nsresult: "0x80570016 (NS_ERROR_XPC_GS_RETURNED_FAILURE)"  location: "JS frame :: chrome://calendar/content/import-export.js :: saveEventsToFile :: line 264"  data: no]
Source File: chrome://calendar/content/import-export.js
Line: 264
]]]
Thanks for filing. I have a WiP patch, but GetService is still failing and I can't quite figure out why.
Assignee: nobody → philipp
Status: NEW → ASSIGNED
Flags: blocking-calendar1.0+
Whiteboard: [needed beta][no l10n impact]
Posted patch Fix - v1 β€” β€” Splinter Review
There we go. This patch takes care. I'll attach a no-whitespace version in just a moment. Seems I totallly forgot to complete the changes for import/export.
Attachment #470316 - Flags: review?(mschroeder)
Here's the no whitespace version.

Also a short summary of what I did to make review easier:

import-export/
* Change Syntax |foo.prototype.bar = function ...| to
  |foo.prototype = { bar: ... }|.
* Change var to let
* Made use of cal.getDateFormatter() where appropriate
* Prefixed some functions with cal.
* Fixed module file and manifest
* Renamed variables called "date" (semi-reserved word) to "dt"

base/content/import-export.js:
* Made loading im/exporters more robust
* Fixed a bug when canceling the filepicker (not bug 450568, but same summary)
* Renamed some variables that are wrong from copy/paste.
Duplicate of this bug: 450568
Whiteboard: [needed beta][no l10n impact] → [needed beta][no l10n impact][needs review]
Comment on attachment 470317 [details] [diff] [review]
Fix - v1 - NO WHITESPACE

r=simon looks good to me, note that I had to hack calendar-common-sets.js so writable returns "true" in order to have a selectable "Import..." option
Comment on attachment 470316 [details] [diff] [review]
Fix - v1

Please set review to + when you give r=simon :)
Attachment #470316 - Flags: review?(mschroeder) → review+
Pushed to comm-central <http://hg.mozilla.org/comm-central/rev/56fca4f727b7>
-> FIXED
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
Target Milestone: --- → Trunk
Whiteboard: [needed beta][no l10n impact][needs review] → [needed beta][no l10n impact]
OS: Windows 7 → All
Hardware: x86 → All
You need to log in before you can comment on or make changes to this bug.