builder documentation link should link to the docs of it's highest supported sdk

RESOLVED INVALID

Status

Add-on SDK
General
P1
normal
RESOLVED INVALID
8 years ago
8 years ago

People

(Reporter: dietrich, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
the docs on the builder at the moment have no examples, which makes dev surprisingly difficult and slow.

why do we have two separate sets?

until the builder docs are fixed (or we stop having two out-of-sync sets) we should just link to the online sdk docs instead.
(Reporter)

Updated

8 years ago
Priority: -- → P1
The builder is going to be the canonical location for the docs, so instead of linking to the online SDK docs, we should be filing and fixing bugs in the docs on the builder.
(Reporter)

Comment 2

8 years ago
That seems like unnecessary duplication of work. It's difficult enough to get people to write docs once, let alone twice.

The developers are writing documentation in the SDK first. Can we make a system that generates builder-themed version of that documentation?
(In reply to comment #2)
> The developers are writing documentation in the SDK first. Can we make a system
> that generates builder-themed version of that documentation?

That's exactly what we do have.  The problem is that there are bugs in the script that generates the docs for the builder.  Thus the right thing to do is to identify and fix those bugs.
(Reporter)

Comment 4

8 years ago
Oh, awesome :) Your comment #1 made it sound like they were a separate set (and the content is so sparse that I assumed they were!).

I'll file a bug on the missing chunks of docs, and am closing this one.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INVALID
The Add-on SDK is no longer a Mozilla Labs experiment and has become a big enough project to warrant its own Bugzilla product, so the "Add-on SDK" product has been created for it, and I am moving its bugs to that product.

To filter bugmail related to this change, filter on the word "looptid".
Component: Jetpack SDK → General
Product: Mozilla Labs → Add-on SDK
QA Contact: jetpack-sdk → general
Version: Trunk → unspecified
You need to log in before you can comment on or make changes to this bug.