bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Crash if I click on the "CVS" link on the page.

VERIFIED DUPLICATE of bug 59130

Status

SeaMonkey
General
P3
critical
VERIFIED DUPLICATE of bug 59130
18 years ago
13 years ago

People

(Reporter: mmclure, Assigned: asa)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.75 [en] (X11; U; Linux 2.2.16-22 i686)
BuildID:    M18

If I open the above URL, and click on either the "CVS" link at the top, or the
"CVS Repository" link near the bottom, Mozilla crashes.
M18 CVS as of 11/04/2000.
If I go directly to the URL for that link
(http://sourceforge.net/cvs/?group_id=11050) Mozilla does not crash.

Mozilla prints the following to stderr before crashing:

Document http://sourceforge.net/projects/avifile loaded successfully
PrefStyleSheet removed
PrefStyleSheet removed
WEBSHELL- = 3
nsWidget::~nsWidget() of toplevel: 14 widgets still exist.
nsWidget::~nsWidget() of toplevel: 9 widgets still exist.
###!!! ASSERTION: You can't dereference a NULL nsCOMPtr with operator->().:
'mRawPtr != 0', file ../../../dist/include/nsCOMPtr.h, line 649
###!!! Break: at file ../../../dist/include/nsCOMPtr.h, line 649
^G/home/mmt/src/mozilla/mozilla/dist/bin/run-mozilla.sh: line 72: 28128
Segmentation fault      $prog ${1+"$@"}


Reproducible: Always
Steps to Reproduce:
1. Go to http://sourceforge.net/projects/aviplay
2. Click on either the "CVS" link at the top or the "CVS Repository" link near
the bottom.
3. Watch Mozilla crash.
I can't reproduce the problem with the 2000110421 trunk build...

The Nov. 4 morning builds of Mozilla had a Linux crasher (bug 59130) that was
fixed in the evening builds.  Try a newer build and see if it still happens?
(Reporter)

Comment 2

18 years ago
Yes - 11/05/2000 CVS solves problem. Probably a duplicate of 59130.

*** This bug has been marked as a duplicate of 59130 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 3

18 years ago
vrfy dupe
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.