Reading a specific HTML mail message causes crash

VERIFIED DUPLICATE of bug 59203

Status

P3
major
VERIFIED DUPLICATE of bug 59203
18 years ago
10 years ago

People

(Reporter: don, Assigned: rhp)

Tracking

({crash})

Trunk
crash

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
I crashed while attempting to read a specific spam HTML email message in my
inbox.  Reading the same message in 4.x does NOT crash.  And reading the HTML
content of the message with the NS6 browser does NOT crash.
(Reporter)

Comment 1

18 years ago
Created attachment 18759 [details]
contents of the evil email
(Reporter)

Comment 2

18 years ago
The evil email is attached.
Keywords: crash, rtm
(Reporter)

Comment 3

18 years ago
Here's the content of the email inline:

From - Sun Nov 05 11:34:14 2000
Return-Path: <susi@mail8.e-solid-savings.com>
Received: from netscape.com ([205.217.237.46]) by dredd.mcom.com
          (Netscape Messaging Server 4.15 dredd Jun 22 2000 16:29:39) with
          ESMTP id G3JC5F00.0P7 for <don@dredd.mcom.com>; Sat, 4 Nov 2000
          20:51:15 -0800
Received: from muffin.netscape.com (muffin.mcom.com [205.217.233.5])
	by netscape.com (8.10.0/8.10.0) with ESMTP id eA54dCs28824
	for <don@mailhub>; Sat, 4 Nov 2000 20:39:12 -0800 (PST)
Received: from netscape.com (shemail.mcom.com [205.217.237.178])
	by muffin.netscape.com (8.8.5/8.8.5) with ESMTP id UAA25523
	for <page-don@muffin.mcom.com>; Sat, 4 Nov 2000 20:51:14 -0800 (PST)
From: susi@mail8.e-solid-savings.com
Received: from xwing.netscape.com (xwing.mcom.com [207.200.76.40])
	by netscape.com (8.10.0/8.10.0) with ESMTP id eA54pDj15419;
	Sat, 4 Nov 2000 20:51:13 -0800 (PST)
Received: from ns.egosys.co.kr (co-locate.bnccom-C5.iAsiaWorks.ne.kr
[210.218.249.11] (may be forged))
	by xwing.netscape.com (8.10.0/8.10.0) with ESMTP id eA54pCR12781;
	Sat, 4 Nov 2000 20:51:12 -0800 (PST)
Received: from 1Cust199.tnt1.kansas-city.mo.da.uu.net_[63.46.255.199]
(1Cust199.tnt1.kansas-city.mo.da.uu.net [63.46.255.199])
	by ns.egosys.co.kr (8.9.3/8.9.3) with SMTP id OAA32543;
	Sun, 5 Nov 2000 14:21:00 +0900
Received: from mail.ccim.be by 1Cust199.tnt1.kansas-city.mo.da.uu.net with
ESMTP; Sun, 05 Nov 2000 22:45:55 -0500
Message-ID: <0000155c223e$00000313$00001f2e@mail.ccim.be>
To: <bobjo@163.net>
Subject: Do you have a "YEN" to be a millionaire?                         7982
Date: Sun, 05 Nov 2000 22:45:48 -0500
MIME-Version: 1.0
Content-Type: text/html;
	charset="iso-8859-1"
Content-Transfer-Encoding: quoted-printable
X-Priority: 3
X-MSMail-Priority: Normal
Reply-To: abob@163.net

<HTML>
<BODY>
<script>
enc =3D "%3C%21DOCTYPE%20HTML%20PUBLIC%20%22-//W3C//DTD%20HTML%203.2//EN%2=
2%3E%0D%0A%3Chtml%3E%0D%0A%0D%0A%3Chead%3E%0D%0A%3Cmeta%20NAME%3D%22GENERA=
TOR%22%20Content%3D%22Microsoft%20FrontPage%203.0%22%3E%0D%0A%3Cmeta%20HTT=
P-EQUIV%3D%22Content-Type%22%20CONTENT%3D%22text/html%3BCHARSET%3Diso-8859=
-1%22%3E%0D%0A%3Ctitle%3EThank%20You%3C/title%3E%0D%0A%3C/head%3E%0D%0A%0D=
%0A%3Cbody%20BGCOLOR%3D%22%23FFFFFF%22%3E%0D%0A%0D%0A%3Cp%3E%3Cfont%20COLO=
R%3D%22%230033FF%22%3E%3Cb%3EDo%20you%20have%20the%20Yen%20to%20be%20a%20M=
illionare%3F%3C/b%3E%3C/font%3E%3Cbr%3E%0D%0A%3Cbr%3E%0D%0A%3Cb%3E%3Cfont%=
20COLOR%3D%22%23000000%22%3E100%25%20return%20in%20less%20than%2090%20days=
%21%3Cbr%3E%0D%0A%3Cbr%3E%0D%0AUnique%20Strategy%20Trading%20in%20the%20In=
ternational%20Currency%20Markets%21%3Cbr%3E%0D%0A%3Cbr%3E%0D%0ALargest%20M=
arketPlace%20in%20the%20World%21%3Cbr%3E%0D%0A%3Cbr%3E%0D%0AGet%20our%20Re=
ports%2C%20Charts%20and%20Strategies%20on%20the%20U.S.%20Dollar%20vs%3Cbr%=
3E%0D%0AJapanese%20yen%20and%20euro%20dollar.%3Cbr%3E%0D%0A%3Cbr%3E%0D%0A%=
3C/font%3E%3Cfont%20COLOR%3D%22%23FF0000%22%3EExample%3A%3C/font%3E%3Cfont=
%20COLOR%3D%22%23000000%22%3E%3Cbr%3E%0D%0A%3Cbr%3E%0D%0AA%20%245%2C000%20=
Investment%20in%20the%20yen%20vs%20the%20dollar%2C%20%26quot%3Bproperly%20=
positioned%26quot%3B%2C%3Cbr%3E%0D%0Aon%2008/18%20could%20have%20returned%=
20%2415%2C000%20on%2009/18/99.%3C/font%3E%3C/b%3E%20%3C/p%3E%0D%0A%3C/body=
%3E%0D%0A%3Cscript%20language%3D%22javascript%22%3E%20setTimeout%28%22wind=
ow.location%20%3D%28%27http%3A//www.hambonehound.com/cgi-bin/mgr.cgi%3F000=
3M%27%29%22%2C0001%29%20%3C/script%3E%0D%0A%0D%0A%3C/html%3E%0D%0A";
dec =3D unescape(enc);
document.write(dec);
</script>

<html>

<head>
<title></title>
</head>

<body>
</body>
</html>



(Reporter)

Comment 4

18 years ago
Adding Chris McAfee to "cc" list.

Comment 5

18 years ago
The mail crashed mozilla on WinNT, Linux rh6.2.
Linux: TB20444096E
(Reporter)

Comment 6

18 years ago
OK, changing platform and OS to "All".
OS: Windows 98 → All
Hardware: PC → All

Comment 7

18 years ago
WinNT: TB20443833X

Comment 8

18 years ago
Adding tb stack trace, sorry it's a little jumbled.
http://cyclone/reports/incidenttemplate.cfm?bbid=20443833

       nsCRT::strtok   [d:\builds\seamonkey\mozilla\xpcom\ds\nsCRT.cpp, line 242]
     MimeInlineTextHTML_parse_line
[d:\builds\seamonkey\mozilla\mailnews\mime\src\mimethtm.cpp, line 192]
     MimeInlineText_rotate_convert_and_parse_line
[d:\builds\seamonkey\mozilla\mailnews\mime\src\mimetext.cpp, line 381]
     convert_and_send_buffer
[d:\builds\seamonkey\mozilla\mailnews\mime\src\mimebuf.cpp, line 123]
     mime_LineBuffer [d:\builds\seamonkey\mozilla\mailnews\mime\src\mimebuf.cpp,
line 245]
     MimeInlineText_parse_decoded_buffer
[d:\builds\seamonkey\mozilla\mailnews\mime\src\mimetext.cpp, line 272]
     mime_decode_qp_buffer
[d:\builds\seamonkey\mozilla\mailnews\mime\src\mimeenc.cpp, line 179]
     MimeDecoderWrite
[d:\builds\seamonkey\mozilla\mailnews\mime\src\mimeenc.cpp, line 598]
     MimeLeaf_parse_buffer
[d:\builds\seamonkey\mozilla\mailnews\mime\src\mimeleaf.cpp, line 154]
     MimeMessage_parse_line
[d:\builds\seamonkey\mozilla\mailnews\mime\src\mimemsg.cpp, line 214]
     convert_and_send_buffer
[d:\builds\seamonkey\mozilla\mailnews\mime\src\mimebuf.cpp, line 123]
     mime_LineBuffer [d:\builds\seamonkey\mozilla\mailnews\mime\src\mimebuf.cpp,
line 245]
     MimeObject_parse_buffer
[d:\builds\seamonkey\mozilla\mailnews\mime\src\mimeobj.cpp, line 254]
     MimeMessage_parse_line
[d:\builds\seamonkey\mozilla\mailnews\mime\src\mimemsg.cpp, line 131]
     MimeMultipart_parse_line
[d:\builds\seamonkey\mozilla\mailnews\mime\src\mimemult.cpp, line 261]
     MimeMultipart_parse_line
[d:\builds\seamonkey\mozilla\mailnews\mime\src\mimemult.cpp, line 261]
     convert_and_send_buffer
[d:\builds\seamonkey\mozilla\mailnews\mime\src\mimebuf.cpp, line 123]
     mime_LineBuffer [d:\builds\seamonkey\mozilla\mailnews\mime\src\mimebuf.cpp,
line 245]
     MimeObject_parse_buffer
[d:\builds\seamonkey\mozilla\mailnews\mime\src\mimeobj.cpp, line 254]
     MimeMessage_parse_line
[d:\builds\seamonkey\mozilla\mailnews\mime\src\mimemsg.cpp, line 214]
     convert_and_send_buffer
[d:\builds\seamonkey\mozilla\mailnews\mime\src\mimebuf.cpp, line 123]
     mime_LineBuffer [d:\builds\seamonkey\mozilla\mailnews\mime\src\mimebuf.cpp,
line 245]
     MimeObject_parse_buffer
[d:\builds\seamonkey\mozilla\mailnews\mime\src\mimeobj.cpp, line 254]
     MimeMessage_parse_line
[d:\builds\seamonkey\mozilla\mailnews\mime\src\mimemsg.cpp, line 131]
     nsStreamConverter::OnDataAvailable
[d:\builds\seamonkey\mozilla\mailnews\mime\src\nsStreamConverter.cpp, line 851]
     nsStreamConverter::OnDataAvailable
[d:\builds\seamonkey\mozilla\mailnews\mime\src\nsStreamConverter.cpp, line 851]
     nsDocumentOpenInfo::OnDataAvailable
[d:\builds\seamonkey\mozilla\uriloader\base\nsURILoader.cpp, line 260]
     InterceptStreamListener::OnDataAvailable
[d:\builds\seamonkey\mozilla\netwerk\cache\mgr\nsCachedNetData.cpp, line 1216]
     nsOnDataAvailableEvent::HandleEvent
[d:\builds\seamonkey\mozilla\netwerk\base\src\nsAsyncStreamListener.cpp, line 406]
     nsStreamListenerEvent::HandlePLEvent
[d:\builds\seamonkey\mozilla\netwerk\base\src\nsAsyncStreamListener.cpp, line 106]
     PL_HandleEvent [d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c, line 581]
     PL_ProcessPendingEvents
[d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c, line 517]
     _md_EventReceiverProc [d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c,
line 1051]
<../images/spacer.gif>
(Reporter)

Comment 9

18 years ago
Win98: TB20435658Y

Comment 10

18 years ago
MIME
Component: Mail Window Front End → MIME
(Reporter)

Comment 11

18 years ago
Re-assigning to component owner.
Assignee: putterman → rhp
(Assignee)

Comment 12

18 years ago
Yes, this is a new crash from the looks of it.

- rhp

*** This bug has been marked as a duplicate of 59203 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE
adding me to the cc list.

Comment 14

18 years ago
Marking verified as duplicate
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.